PAT-A 1036 Boys vs Girls (25 分)

1036 Boys vs Girls (25 分)

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student's namegenderID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F​​−grade​M​​. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60

Sample Output 2:

Absent
Jean AA980920
NA

思路:男生女生分别保存在各自的vector中,按照分数进行从小到大排序。

#include <iostream>
#include <string>
#include <algorithm>
#include <vector>

using namespace std;

typedef struct student
{
    string name;
    char gender;
    string id;
    int score;
    student(string n, char g, string i, int s):name(n), gender(g), id(i), score(s){}
}stu;

bool cmp(stu a, stu b)
{   //按分数降序排序
    return a.score < b.score;
}

int main()
{
    int k;
    string name;
    string id;
    char gender;
    int score;
    vector<stu> males;
    vector<stu> females;

    cin >> k;
    for(int i = 0; i < k; i++)
    {
        cin >> name >> gender >> id >> score;
        if(gender == 'M')
            males.push_back(stu(name, gender, id, score));
        else
            females.push_back(stu(name, gender, id, score));
    }

    sort(males.begin(), males.end(), cmp);
    sort(females.begin(), females.end(), cmp);

    bool flag1 = males.size();//记录输入是否有男生
    bool flag2 = females.size();
    //输出女生信息
    if(false == flag2)//没有女生
        cout << "Absent" << endl;
    else
        cout << females[females.size() - 1].name << " " << females[females.size() - 1].id << endl;
    //输出男生信息
    if(false == flag1)//没有男生
        cout << "Absent" << endl;
    else
        cout << males[0].name << " " << males[0].id << endl;
    //输出分数信息
    if(flag1 && flag2)//男生女生都有
        cout << females[females.size() - 1].score - males[0].score;
    else
        cout << "NA";
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值