PAT-A 1067 Sort with Swap(0, i) (25 分)

1067 Sort with Swap(0, i) (25 分)

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

分析:设置一个set来记录未排好序的数字,每排好一个数字,将这个数字从set中删除,设置一个map保存从数字到这个数字的下标的映射。

坑点:当还没有排好序的时候,如果0的下标是0,这个时候需要找任意一个位置错乱的数将0换出来。如下所示。

Swap:(0, 7)
Swap:(0, 2)
Swap:(0, 3)
Swap:(0, 1)这里是把0换出来
Swap:(0, 9)
Swap:(0, 6)
Swap:(0, 4)
Swap:(0, 5)
Swap:(0, 1)

#include <bits/stdc++.h>

using namespace std;

int main()
{
    int n, temp;
    scanf("%d", &n);
    map<int, int> index;//number -> index
    set<int> bad;//还没有找到正确位置的数字
    for(int i = 0; i < n; i++)
    {
        scanf("%d", &temp);
        if(temp != 0 && temp != i)
            bad.insert(temp);//记录位置不对的数字
        index.insert({temp, i});//保存所有数字及其下标
    }

    int num = 0;//交换次数
    while(bad.size() != 0)//还有位置错乱的数字,继续进行交换
    {
        num++;
        int index0 = index[0];//0的下标
        if(index0 == 0)//未排好序,需要将0换出来
        {
            int badmin = *bad.begin();//当前位置不对的最小的数
            int indexmin = index[badmin];//该数在数组中的下标
           // printf("Swap:(0, %d)这里是把0换出来\n", badmin);
            index[0] = indexmin;//把0放到该数的位置上
            index[badmin] = 0;//把该数放到下标0处
        }
        else
        {
           // printf("Swap:(0, %d)\n", index0);
            index[0] = index[index0];//0的下标这个数在数组中的下标
            bad.erase(index0);//0的下标表示的数排序完成
        }
    }
    printf("%d", num);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值