PAT 1067 Sort with Swap(0, i)(25 分)(用指定方法排序)

该博客介绍了PAT 1067编程题,要求使用特定操作(仅允许交换0和其他位置的数字)来对数组进行排序,并找到达到升序排序所需的最小交换次数。博主提供了问题的输入输出规格、样例输入输出,并分享了实现这一目标的算法思路和代码实现。
摘要由CSDN通过智能技术生成

Given any permutation of the numbers {0, 1, 2,..., N−1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (≤10​5​​) followed by a permutation sequence of {0, 1, ..., N−1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

题解:用题目给的指定方法排序,只用0与其它位交换,问最小的交换次数。定义一个变量left记录当前数字没有归位的数量。使交换次数最小的办法是让0与本来应该在它当前所在位的数字交换,若0在其本位,则往右寻找第一个不是在本位的数字交换。可以直接使用#include<algorithm>头文件下的swap()函数。

代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=100005;
int pos[maxn];
int main()
{
    int n,num;
    int ans=0;
    
    cin>>n;
    int left=n-1;  //除0以外未归位的个数
    for(int i=0;i<n;i++)
    {
        cin>>num;
        pos[num]=i;
        if(num==i&&num!=0)
            left--;  //未归位的数字个数
    }
    int k=1;         //除0以外当前不在本位最小的数
    while(left>0)
    {
        if(pos[0]==0) //如果0在本位
        {
            while(k<n)
            {
                if(pos[k]!=k)
                {
                    swap(pos[0],pos[k]);
                    ans++;
                    break;
                }
                k++;
            }
        }
        while(pos[0]!=0)
        {
            swap(pos[0],pos[pos[0]]);
            ans++;
            left--;
        }
    }
    cout<<ans<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值