PAT-A 1038 Recover the Smallest Number (30 分)

1038 Recover the Smallest Number (30 分)

Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given { 32, 321, 3214, 0229, 87 }, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.

Input Specification:

Each input file contains one test case. Each case gives a positive integer N (≤10​4​​) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the smallest number in one line. Notice that the first digit must not be zero.

Sample Input:

5 32 321 3214 0229 87

Sample Output:

22932132143287

思路:这题我不会,看的算法笔记。贪心策略:如果数字串s1+s2<s2+s1(加号表示拼接),也就是说s1+s2拼接后表示的数字比s2+s1拼接后表示的数字小,那么把s1放在s2的前面,否则把s2放在s1的前面。注意拼接后要去除前导零,另外注意所有数字都是零的情况。

#include <bits/stdc++.h>
#define maxn 10005
using namespace std;

bool cmp(string s1, string s2)
{   //s1+s2拼接起来比s2+s1拼接起来小的时候,s1应该排在s2的前面
    return s1 + s2 < s2 + s1;
}

string str[maxn];
int main()
{
    int n;
    cin >> n;
    for(int i = 0; i < n; i++)
        cin >> str[i];
    sort(str, str + n, cmp);

    string result;
    for(int i = 0; i < n; i++)
        result += str[i];//拼接处结果

    while(!result.empty() && result[0] == '0')
        result.erase(result.begin());//去除前导零

    if(result.size() == 0)//拼接出来的数字为0
        cout << "0";
    else
        cout << result;

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值