PAT-A 1064 Complete Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

思路:根据完全平衡二叉树的结构特点,计算出一个序列中根节点的位置,使用先序遍历建树。(使用中序遍历更方便)

#include <cstdio>
#include <vector>
#include <queue>
#include <cmath>
#include <algorithm>

using namespace std;

typedef struct Node
{
    Node* left;
    Node* right;
    int v;
}node;

node* newNode(int v)
{
    node* tem = new node();
    tem->v = v;
    tem->left = tem->right = nullptr;
    return tem;
}


void levelTranverse(node* root, vector<int> &result)
{
    queue<node*> q;
    q.push(root);
    while(!q.empty())
    {
        node* tem = q.front();
        result.push_back(tem->v);
        if(tem->left != nullptr) q.push(tem->left);
        if(tem->right != nullptr) q.push(tem->right);
        q.pop();
    }
}
// 给定一串数据,计算出以该序列为完全平衡二叉树时,根节点的位置
int findRoot(vector<int> v, int l, int r)
{
    int n = r - l + 1;
    if(n == 1)
        return l;
    // 计算树的层次
    int level;
    for(level = 1; (int)pow(2, level) - 1 < n; level++) ;

    int n1 = (int)pow(2, level - 2) - 1;//左子树上除去最后一层的结点数
    int n2 = (int)pow(2, level - 1) - 1;//除最后一层结点外,树中的结点数
    int n3 = n - n2; // 最后一层的节点数
    int n4 = min(n3, (int)pow(2, level - 2)); // 左子树的最后一层节点数
    int leftNum = n4 + n1;
    return l + leftNum;
}

void create(node* &root, vector<int> v, int l, int r)
{
    if(l <= r)
    {
        int leftNum = findRoot(v, l, r);
        root = newNode(v[leftNum]);
        create(root->left, v, l, leftNum - 1);
        create(root->right, v, leftNum + 1, r);
    }
}

void preOrder(node* root, vector<int> &result)
{
    if(root == nullptr) return;
    result.push_back(root -> v);
    preOrder(root->left, result);
    preOrder(root->right, result);
}
int main()
{
    int n;
    vector<int> in, result;
    scanf("%d", &n);
    for(int i =0; i < n; i++)
    {
        int tem;
        scanf("%d", &tem);
        result.push_back(tem);
    }
    if(n == 1)
    {
        printf("%d\n", result[0]);
        return 0;
    }
    sort(result.begin(), result.end());
    node* root = nullptr;
    create(root, result, 0, n - 1);
    result.clear();
    levelTranverse(root, result);
    for(int i = 0; i < n; i++)
    {
        if(i != 0)
            printf(" ");
        printf("%d", result[i]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值