HDU 1002 A + B Problem II

ACM OJ题解目录
本题网址:https://cn.vjudge.net/problem/HDU-1002

A + B Problem II

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 
Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 
Sample Input
2
1 2
112233445566778899 998877665544332211
 
Sample Output
Case 1:
1 + 2 = 3
 
Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

题目大意:
  大整数加法,长度最多为1000。
  
分析:
  首先,大数运算要用字符串来处理;其次,加法运算要考虑进位问题。
  因此,采用字符串存储,利用ascall码来做运算,再加上一个进位计算,即可轻松解决。
  当然,不会让你们失望的,我的小明同学又出错了。因为题说输出两个测试用例之间的空行,所以最后一个用例下面记得不要输出空行啦~
  
代码如下:

#include <iostream>
#include <algorithm> 
#include <cstring>
using namespace std;

const int maxn = 1000 + 5;
int t;
char s1[maxn], s2[maxn];

void add(char *a, char *b)
{
	int alen = strlen(a) - 1;
	int blen = strlen(b) - 1;
	int clen = max(alen, blen) + 1;
	int carry = 0;
	char c[maxn], *res = c;
	memset(c, 0, maxn * sizeof(char));
	
	while(alen >= 0 && blen >= 0)
	{
		res[clen] = a[alen] + b[blen] - '0' + carry;
		if(res[clen] <= '9') carry = 0;	//不用进位 
		else
		{	//进位 
			carry = 1;
			res[clen] -= 10;
		}
		alen--, blen--, clen--;
	}
	
	while(alen >= 0)
	{	//如果a有剩余 
		res[clen] = a[alen] + carry;
		if(res[clen] <= '9') carry = 0;
		else
		{
			carry = 1;
			res[clen] -= 10;
		}
		alen--, clen--;
	}
	
	while(blen >= 0)
	{	//如果b有剩余 
		res[clen] = b[blen] + carry;
		if(res[clen] <= '9') carry = 0;
		else
		{
			carry = 1;
			res[clen] -= 10;
		}
		blen--, clen--;
	}
	
	if(clen >= 0)
	{	//如果还有进位 
		res[clen] = carry + '0';
	}
	
	if(res[0] == '0') res++;	//去除首位0 
	
	cout << a << " + " << b << " = " << res << endl;
}

int main()
{
	cin >> t;
	
	for(int i = 1; i <= t; i++)
	{
		memset(s1, 0, maxn * sizeof(char));
		memset(s2, 0, maxn * sizeof(char));
		
		cin >> s1 >> s2;
		cout << "Case " << i << ":" << endl;
		add(s1, s2);
		if(i < t) cout << endl;
	}
	
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值