树结构练习——排序二叉树的中序遍历
Time Limit: 1000MS
Memory Limit: 65536KB
Problem Description
在树结构中,有一种特殊的二叉树叫做排序二叉树,直观的理解就是——(1).每个节点中包含有一个关键值 (2).任意一个节点的左子树(如果存在的话)的关键值小于该节点的关键值 (3).任意一个节点的右子树(如果存在的话)的关键值大于该节点的关键值。现给定一组数据,请你对这组数据按给定顺序建立一棵排序二叉树,并输出其中序遍历的结果。
Input
输入包含多组数据,每组数据格式如下。
第一行包含一个整数n,为关键值的个数,关键值用整数表示。(n<=1000)
第二行包含n个整数,保证每个整数在int范围之内。
Output
为给定的数据建立排序二叉树,并输出其中序遍历结果,每个输出占一行。
Example Input
1 2 2 1 20
Example Output
2 1 20
Hint
#include <bits/stdc++.h>
using namespace std;
int a[1005];
struct node
{
int data;
node* lchild;
node* rchild;
};
node*newNode(int v)
{
node* Node=new node;
Node->data=v;
Node->lchild=Node->rchild=NULL;
return Node;
}
void insert(node* &root,int x)
{
if(root==NULL)
{
root=newNode(x);
return;
}
if(x<root->data)
{
insert(root->lchild,x);
}
else
{
insert(root->rchild,x);
}
}
node* Create(int* data,int n)
{
node* root=NULL; //这是保证第一个节点能顺利插入
for(int i=0;i<n;i++) //数组从0开始,很方便
{
insert(root,data[i]); //注意,指针的指针,加上引用
}
return root;
}
vector<int> ans;
void zhongxu(node* root)
{
if(root->lchild!=NULL) zhongxu(root->lchild);
ans.push_back(root->data);
if(root->rchild!=NULL) zhongxu(root->rchild);
}
int main()
{
int n1;
while(cin>>n1)
{
ans.clear();
memset(a,0,sizeof(a));
for(int i=0;i<n1;i++)
{
scanf("%d",&a[i]);
}
node* root=Create(a,n1);
zhongxu(root);
for(int i=0;i<ans.size();i++)
{
cout<<ans[i];
if(i!=ans.size()-1) cout<<' ';
}
cout<<endl;
}
return 0;
}