Problem M: 有多少个0

Problem M: 有多少个0

Time Limit: 1 Sec Memory Limit: 16 MB

Description

1*2*3*……*n的乘积以多少个0结尾。

Input

输入为多行,至EOF结束。每行为一个整数n,n<=100000。

Output

输出每个n对应的结尾0的个数。

Sample Input

10
100
1000
10000

Sample Output

2
24
249
2499

思路

思路来源:https://blog.csdn.net/weixin_39296576/article/details/90400373

求n!中5出现的次数。

代码

#include "stdio.h"

int numberOfFive(int n)
{
    if (n < 5)
        return 0;
    n/=5;
    return n+numberOfFive(n);
}

int main()
{
    int n;
    while (scanf("%d", &n) != EOF)
    {
        int sum=0;
        sum=numberOfFive(n);
        printf("%d\n",sum);
    }
    return 0;
}
/*
参考链接:https://blog.csdn.net/weixin_39296576/article/details/90400373
*/

参考资料-思路来源

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值