hdoj 1124 Factorial

Factorial


题目含义:计算N!末尾有多少个 0。



Sample Input
 
 
6 3 60 100 1024 23456 8735373
 

Sample Output
 
 
0 14 24 253 5861 2183837

末尾为零必定是2*5=10,且2的因子数必定大于5的因字数。

算术基本定理中n!的素因子分解中的素数p的幂为[n/p]+[n/p²]+[n/p³]+……
#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
    int T,n,sum,tmp;
    scanf("%d",&T);
    while(T--)
    {
        sum = 0;
        tmp = 5;
        scanf("%d",&n);
        while(tmp<=n)
        {
            sum += n / tmp;
            tmp *= 5;
        }
        printf("%d\n",sum);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值