Factorial

数论思维——Factorial

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.
ACM technicians faced a very interesting problem recently. Given a set of BTSes to visit, they needed to find the shortest path to visit all of the given points and return back to the central company building. Programmers have spent several months studying this problem but with no results. They were unable to find the solution fast enough. After a long time, one of the programmers found this problem in a conference article. Unfortunately, he found that the problem is so called “Travelling Salesman Problem” and it is very hard to solve. If we have N BTSes to be visited, we can visit them in any order, giving us N! possibilities to examine. The function expressing that number is called factorial and can be computed as a product 1.2.3.4…N. The number is very high even for a relatively small N.
he programmers understood they had no chance to solve the problem. But because they have already received the research grant from the government, they needed to continue with their studies and produce at least some results. So they started to study behaviour of the factorial function.
For example, they defined the function Z. For any positive integer N, Z(N) is the number of zeros at the end of the decimal form of number N!. They noticed that this function never decreases. If we have two numbers N1 < N2, then Z(N1) <= Z(N2). It is because we can never “lose” any trailing zero by multiplying by any positive number. We can only get new and new zeros. The function Z is very interesting, so we need a computer program that can determine its value efficiently.
Input
There is a single positive integer T on the first line of input. It stands for the number of numbers to follow. Then there is T lines, each containing exactly one positive integer number N, 1 <= N <= 1000000000.
Output
For every number N, output a single line containing the single non-negative integer Z(N).
Sample Input
6
3
60
100
1024
23456
8735373
Sample Output
0
14
24
253
5861
2183837
题目大意:GSM网络最重要的部分是所谓的基站收发站(BTS)。这些收发器形成了称为cell的区域(这一术语为移动电话起了名字),每个电话都以最强的信号(在一个简单的视图中)连接到BTS。当然,btse需要注意,技术人员需要定期检查其功能。ACM技术人员最近面临一个非常有趣的问题。给定一组要访问的bts,他们需要找到访问所有给定点的最短路径,然后返回到中心公司大楼。程序员花了几个月的时间研究这个问题,但没有结果。他们无法足够快地找到解决办法。过了很长时间,一位程序员在一篇会议文章中发现了这个问题。不幸的是,他发现这个问题被称为“旅行推销员问题”,很难解决。如果我们有N个bts要访问,我们可以以任何顺序访问它们,给我们N!检查的可能性。表示该数字的函数称为阶乘,可以计算为乘积1.2.3.4…N。即使对于一个相对较小的N,这个数字也是非常高的。程序员明白他们没有机会解决这个问题。但是因为他们已经获得了来自政府的研究资助,他们需要继续他们的研究并至少产生一些结果。他们开始研究阶乘函数的行为。例如,他们定义了函数Z。对于任何正整数N, Z(N)是数字N的小数形式末尾的0的个数! !他们注意到这个函数从不减少。如果有两个数字N1 < N2,那么Z(N1) <= Z(N2)这是因为我们永远不可能通过乘以任何正数而“失去”后面的任何零。我们只能得到越来越多的0。函数Z非常有趣,所以我们需要一个计算机程序来有效地确定它的值。

就是题长,其实很简单,求末尾0的个数,其实就是看有多少个5的倍数(5*2=10,而2的倍数一定比5的倍数多),只要想到这点,代码就很简单了。

    #include <iostream>
    #include <stdio.h>
    using namespace std;
    int main()
    {
        int n,k,sum=0;
        scanf("%d",&n);
        while(n--)
        {
            scanf("%d",&k);
            while(k>=5)
            {
                while(k%5!=0) k--;
                while(k%5==0)
                {
                    k=k/5;
                    sum=sum+k;
                }
            }
            printf("%d\n",sum);
            sum=0;
        }
        return 0;
    }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值