2月3日 Visible Lattice Points(欧拉函数)

Description


A lattice point (x, y) in the first quadrant (x and y are integers greater than or equal to 0), other than the origin, is visible from the origin if the line from (0, 0) to (x, y) does not pass through any other lattice point. For example, the point (4, 2) is not visible since the line from the origin passes through (2, 1). The figure below shows the points (x, y) with 0 ≤ x, y ≤ 5 with lines from the origin to the visible points.




Write a program which, given a value for the size, N, computes the number of visible points (x, y) with 0 ≤ x, y ≤ N.


Input


The first line of input contains a single integer C (1 ≤ C ≤ 1000) which is the number of datasets that follow.


Each dataset consists of a single line of input containing a single integer N (1 ≤ N ≤ 1000), which is the size.


Output


For each dataset, there is to be one line of output consisting of: the dataset number starting at 1, a single space, the size, a single space and the number of visible points for that size.


Sample Input


4
2
4
5
231
Sample Output


1 2 5
2 4 13
3 5 21

4 231 32549


就是找不大于自身互质整数的个数(欧拉函数),把图分成两个三角,注意(1,1)这个点是共享的。

用素数筛的方法。

离线算可能更快一点(不需要多次memset重新算),但没有试。

#include<cstdio>
#include<algorithm>
#define maxn 100005
int phi[maxn],pri[maxn],notpri[maxn];
void euler(int n)
{
	memset(phi, 0, sizeof(phi));
	memset(pri, 0, sizeof(pri));
	memset(notpri, 0, sizeof(notpri));
	phi[1] = 1;
	int cnt = 0;
	for (int i = 2; i <= n; i++)
	{
		if (!notpri[i])
		{
			pri[cnt++] = i;
			phi[i] = i - 1;
		}
		for (int j = 0; j < cnt; j++)
		{
			if (i*pri[j] > n)break;
			notpri[i*pri[j]] = 1;
			if (i%pri[j]==0)
			{
				phi[i*pri[j]] = phi[i]*pri[j];
				break;
			}
			phi[i*pri[j]] = phi[i] * (pri[j]-1);
		}
	}
}
int main()
{
	int t;
	scanf("%d", &t);
	for (int i = 0; i < t; i++)
	{
		int m,sum=0;
		scanf("%d", &m);
		euler(m);
		for (int j = 2; j <= m; j++)
		{
			sum += phi[j];
		}
		sum += 1;
		sum *= 2;
		sum += 1;
		printf("%d %d %d\n", i+1,m,sum);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

_viceversa

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值