HDOJ2088 Box of Bricks

Box of Bricks

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 18367    Accepted Submission(s): 5994


Problem Description
Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. “Look, I've built a wall!”, he tells his older sister Alice. “Nah, you should make all stacks the same height. Then you would have a real wall.”, she retorts. After a little consideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimum number of bricks moved. Can you help?
 

Input
The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line contains n numbers, the heights hi of the n stacks. You may assume 1≤n≤50 and 1≤hi≤100.

The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.

The input is terminated by a set starting with n = 0. This set should not be processed.
 

Output
For each set, print the minimum number of bricks that have to be moved in order to make all the stacks the same height.
Output a blank line between each set.
 

Sample Input
  
  
6 5 2 4 1 7 5 0
 

Sample Output
  
  
5
 
这道题其实也是很坑的,也就是PE的问题,和2093 算菜价是一个道理的,都需要一个flag来标记第一个案例
打印第一个案例的时候只换行,然后之后的案例在输出之前都输出一个空行

另外,题目是让我们计算最小的移动次数,也就是一列加一,另一列减一算一次
这样,我们只算加一或减一的就OK了

下面AC代码:

import java.util.Scanner;

public class Main{
	private static Scanner scanner;

	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		boolean boo = true;
		while (scanner.hasNext()) {
			int n = scanner.nextInt();
			if (n == 0) {
				break;
			}
			if (!boo) {
				System.out.println();
			}
			int sum = 0;// 总和
			int arr[] = new int[n];
			for (int i = 0; i < arr.length; i++) {
				arr[i] = scanner.nextInt();
				sum += arr[i];
			}
			int ave = sum / n;// 平均值
			int count = 0;// 最小次数
			for (int i = 0; i < arr.length; i++) {
				if (arr[i] > ave) {
					count += arr[i] - ave;
				}
			}	
			System.out.println(count);
			boo = false;
		}
	}
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值