HDOJ1008 Elevator

Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 77235    Accepted Submission(s): 42436


Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
 

Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
 

Output
Print the total time on a single line for each test case.
 

Sample Input
  
  
1 2 3 2 3 1 0
 

Sample Output
  
  
17 41
 
可能是我没看清题意吧,被坑了好久。
题目是说:电梯刚开始在0层,上一层需要6秒,下一层需要4秒,每一次停留5秒。
例子中的第一个数是N!之后跟着N个数。
例如第二个例子:N是3,之后是3个数,这三个数才是电梯需要停留的列表!
下面提供三种解题方法的AC代码:

第一种:使用数组记录每一个输入
import java.util.Scanner;

public class Main {
    private static Scanner scanner;

    public static void main(String[] args) {
        scanner = new Scanner(System.in);
        while (scanner.hasNext()) {
            int n = scanner.nextInt();
            if(n == 0){
                break;
            }
            int time = 0;
            int arr[] = new int[n+1];
            for (int i = 1; i < n+1; i++) {
                arr[i] = scanner.nextInt();
            }
            for (int i = 1; i < arr.length; i++) {
                int floor = arr[i] - arr[i-1];
                if (floor > 0) {// 向上
                    time = time + floor * 6;
                } else if (floor < 0) {// 向下
                    time = time - floor * 4;
                }
                time += 5;
            }
            
            System.out.println(time);
        }
    }
}

第二种:将数组部分简化,换成两个变量
import java.util.Scanner;

public class Main{
    private static Scanner scanner;

    public static void main(String[] args) {
        scanner = new Scanner(System.in);
        while (scanner.hasNext()) {
            int n = scanner.nextInt();
            if(n == 0){
                break;
            }
            int time = 0;
            int thisf = 0;
            int nextf = 0;
            for (int i = 1; i < n+1; i++) {
                nextf = scanner.nextInt();
                int floor = nextf - thisf;
                if (floor > 0) {// 向上
                    time = time + floor * 6;
                } else if (floor < 0) {// 向下
                    time = time - floor * 4;
                }
                thisf = nextf;
                time += 5;
            }
            
            System.out.println(time);
        }
    }
}

第三种:进一步简化!
import java.util.Scanner;

public class Main {
    private static Scanner scanner;
    public static void main(String[] args) {
        scanner = new Scanner(System.in);
        int n = scanner.nextInt();
        while (n!=0) {
            int thisf = 0,nextf = 0,time = 0;
            while(n-->0){
                nextf = scanner.nextInt();
                time += nextf>thisf?(nextf-thisf)*6+5:(thisf-nextf)*4+5;
                thisf = nextf;
            }
            System.out.println(time);
            n = scanner.nextInt();
        }
    }
}
Run IDSubmit TimeJudge StatusPro.IDExe.TimeExe.MemoryCode Len.LanguageAuthor
230198232017-11-26 16:31:34Accepted1008265MS9564K640 BJava逸川同学
230198122017-11-26 16:31:10Accepted1008265MS9568K667 BJava逸川同学
230198022017-11-26 16:30:40Accepted1008312MS9576K457 BJava逸川同学



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值