HDOJ1163 Eddy's digital Roots

Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7234    Accepted Submission(s): 3976


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.
 

Input
The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).
 

Output
Output n^n's digital root on a separate line of the output.
 

Sample Input
  
  
2 4 0
 

Sample Output
  
  
4 4
  数根:举个栗子,n=999,将n的每一位拿出来相加得到27,27大于9,再做同样的操作得到9,9不大于9。
所以n的数根就是9,其他都一样。
然后题目是要我们求n^n的数根。
经过实践发现,(假设count(n)为计算数根的函数):
count(n^n)=count(n*n)*n^n-2=count(count(n*n)*n)*n^n-3=....
也就是说先求出平方的数根,然后拿这个数根和n的积再求数根,如此类推。。。

再者是如何求数根
求数根可以根据例子的方法翻译,也可以使用九余数定理
1:
import java.util.Scanner;

public class Main{

	private static Scanner scanner;

	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			int n = scanner.nextInt();
			if (n == 0) {
				break;
			}
			int t = n;
			for (int i = 1; i < n; i++) {
				t = count(t * n);
			}
			System.out.println(t);
		}
	}

	// 计算n的数根
	public static int count(int n) {
		int v = n, res;
		while (v > 9) {
			res = 0;
			while (v > 0) {
				res += v % 10;
				v /= 10;
			}
			v = res;
		}
		return v;
	}
}

2:
import java.util.Scanner;

public class Main{
	private static Scanner scanner;

	public static void main(String[] args) {
		scanner = new Scanner(System.in);
		while (scanner.hasNext()) {
			int n = scanner.nextInt();
			if(n == 0){
				break;
			}
			int t = n;
			for (int i = 1; i < n; i++) {
				t = t * n % 9;// 九余数定理
			}
			if (t == 0) {
				System.out.println("9");
			} else {
				System.out.println(t);
			}
		}
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值