HDOJ1236 排名

排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25092    Accepted Submission(s): 9233


Problem Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。
 

Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
 

Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。
 

Sample Input
  
  
4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
 

Sample Output
  
  
3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20
Hint
Huge input, scanf is recommended.
  题目的参数比较多,需要注意区分。
我这里使用了内部类以及集合来做,内部类用来包装学生的信息,集合用来存放学生,方便排序以后进行输出。
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;
import java.io.PrintWriter;
import java.io.StreamTokenizer;
import java.util.ArrayList;
import java.util.List;

public class Main {
    private static List<Person>list;
    public static void main(String[] args) throws IOException {
        StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
        PrintWriter out = new PrintWriter(new OutputStreamWriter(System.out));
        while (in.nextToken() != StreamTokenizer.TT_EOF) {
            list = new ArrayList<Person>();
            int stNum = (int) in.nval;//学生人数
            if(stNum == 0){
                break;
            }
            in.nextToken();
            int prNum = (int)in.nval;//题目数量
            in.nextToken();
            int score = (int)in.nval;//分数线
            int prScore[] = new int[prNum];//每个题目对应的分数
            for (int i = 0; i < prNum; i++) {
                in.nextToken();
                prScore[i]= (int) in.nval; 
            }
            for (int i = 0; i < stNum; i++) {
                in.nextToken();
                String id = in.sval;
                in.nextToken();
                int passNum = (int) in.nval;//过了的科目数量
//                System.out.println("ID="+id+"  "+passNum);
                int sum = 0;
                for (int j = 0; j < passNum; j++) {
                    in.nextToken();
                    int t = (int) in.nval;
                    sum+=prScore[t-1];
                }
//                System.out.println("sum="+sum);
                if(sum>=score){
                    Main p = new Main();
                    Person person = p.new Person(id,sum);
                    list.add(person);
                }
            }
            sort();//排序
            out.println(list.size());
            out.flush();
            for (int i = 0; i < list.size(); i++) {
                out.println(list.get(i).getId()+" "+list.get(i).getSumScore());
                out.flush();
            }
        }
    }
    public static void sort(){
        //先排分数,再排名字
        for (int i = 0; i < list.size()-1; i++) {
            for (int j = i+1; j < list.size(); j++) {
                int is = list.get(i).getSumScore();
                int js = list.get(j).getSumScore();
                String it = list.get(i).getId();
                String jt = list.get(j).getId();
                if(is<js){
                    list.get(i).setSumScore(js);
                    list.get(j).setSumScore(is);
                    list.get(i).setId(jt);
                    list.get(j).setId(it);
                }else if(is == js){
                    if(it.compareTo(jt)>0){
                        list.get(i).setSumScore(js);
                        list.get(j).setSumScore(is);
                        list.get(i).setId(jt);
                        list.get(j).setId(it);
                    }
                }
            }
        }
    }
    class Person{
        String id;
        int sumScore;
        public Person(String id, int sumScore) {
            super();
            this.id = id;
            this.sumScore = sumScore;
        }
        public Person() {
            super();
        }
        public String getId() {
            return id;
        }
        public void setId(String id) {
            this.id = id;
        }
        public int getSumScore() {
            return sumScore;
        }
        public void setSumScore(int sumScore) {
            this.sumScore = sumScore;
        }
        
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值