ACMA - MG loves gold

MG is a lucky boy. He is always be able to find gold from underground.

It is known that the gold is a sequence with n n elements, which has its own color C C.

MG can dig out a continuous area of sequence every time by using one shovel, but he's unwilling to dig the golds of the same color with one shovel.

As a greedy person, he wish to take all the n golds away with least shovel.
The rules also require MG not to dig twice at the same position.

MG thought it very easy and he had himself disdained to take the job. As a bystander, could you please help settle the problem and calculate the answer? Input
The first line is an integer T T which indicates the case number.( 1<=T<=10 1<=T<=10)

And as for each case, there are 1 1 integer n n in the first line which indicate gold-number( 1<=n<=100000 1<=n<=100000).

Then there are n n integers C C in the next line, the x-th integer means the x-th gold’s color( |C|<=2000000000 |C|<=2000000000).
Output
As for each case, you need to output a single line.

there should be one integer in the line which represents the least possible number of shovels after taking away all n n golds.
Sample Input
2
5
1 1 2 3 -1
5
1 1 2 2 3
Sample Output

23


#include<iostream>
#include<string.h>
#include<algorithm>
#include<math.h>
#include<stdio.h>
#include<stack>
#include<set>
using namespace std;

int main()
{
	int t,n;
	while (~scanf("%d",&t))
	{
		while (t--)
		{
			set<int>q;
			scanf("%d", &n);
			int sum = 1;
			int a;
			for (int i = 0; i < n; i++)
			{
				scanf("%d", &a);
				if (q.count(a))
				{
					q.clear();
					q.insert(a);
					sum++;
				}
				else
				{
					q.insert(a);
				}
			}
			printf("%d\n", sum);
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值