swustoj(667)

存钱(0667)

Time limit(ms): 1000
Memory limit(kb): 65535
Submission: 1965
Accepted: 1466
Accepted
设银行整存零取一年的月利率为n( 0 < n < 1, double)。我手上有一些钱,我想在m( 0 < m < 100, int)年后取出k( 0 < k < 100000, int)元,到第m年恰好取完,那么我应该存多少钱?
Description
一行数据包含n,m,k用一个空格隔开
Input
存钱数,保留两位小数
Output

0.0059 10 10000
Sample Input

69976.82
Sample Output
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <map>
#include <cstring>
using namespace std;

int main()
{
	double n, m;
	double x,t;
	while (cin>>x>>n>>m) 
	{
		t = 0;
		for (int i = 0; i < n; i++)
		{
			t = (t + m) / (1 + 12 * x);
		}
		printf("%.2lf\n", t);
	}
	return 0;
}
水题

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值