NBA Finals

Consider two teams, Lakers and Celtics, playing a series ofNBA Finals until one of the teams wins n games. Assume that the probabilityof Lakers winning a game is the same for each game and equal to p andthe probability of Lakers losing a game is q = 1-p. Hence, there are noties.Please find the probability of Lakers winning the NBA Finals if theprobability of it winning a game is p.
输入
first line input the n-games (7<=n<=165)of NBA Finals 
second line input the probability  of Lakers winning a game p (0< p < 1)
输出
the probability  of Lakers winning the NBA Finals
样例输入
7
0.4
样例输出
0.289792
提 交
gcc
1
 
1

动态规划,状态转移,将前面的每一个状态转移到下一个状态,dp的基本操作,坑点,全败和全胜需要特判
#include <stdio.h>
#include <math.h>
#include <stdlib.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;

int main()
{
	int n;
	double dp[200][200];
	cin >> n;
	double p;
	cin >> p;
	dp[0][0] = 1.0;
	for (int i = 1; i <= n; i++) {
		for (int j = 0; j <= i; j++) {
			if (j == 0)dp[i][j] = dp[i - 1][j] * (1 - p);
			else if (j == i)dp[i][j] = dp[i - 1][j - 1] * p;
			else dp[i][j] = dp[i - 1][j] * (1 - p) + dp[i - 1][j - 1] * p;
		}
	}
	double ans = 0;
	for (int i = (n + 1) / 2; i <= n; i++) {
		ans += dp[n][i];
	}
	cout << ans << endl;
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值