pat 甲级 1027

1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:

Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:

For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:

15 43 71

Sample Output:

#123456

这题还是比较简单的,但是这里还是记录一下吧。

题目的意思其实就是把10进制数转换成13进制数。采用的方法也非常常规,和10进制转2进制的思路是一样的。

代码如下:

#include<iostream>
#include<vector>
#include<stack>
using namespace std;
void outPutChar(int i)
{
	if (i==10)
	{
		cout<<'A';
	}
	else if (i ==11)
	{
		cout <<'B';
	}
	else if (i ==12)
	{
		cout<<'C';
	}
	else
	{
		cout << i;
	}
}
int main()
{
	vector<int> arr(3);
	for (int i = 0; i < 3; i++)
	{
		int temp;
		cin >> temp;
		arr[i]=temp;
	}
	cout <<"#";
	stack<int> s;
	for (int i = 0; i < 3; i++)
	{
		while (arr[i])
		{
			s.push(arr[i]%13);
			arr[i] /= 13;
		}
		if (s.size() == 1)
		{
			cout <<"0";
			outPutChar(s.top());
			s.pop();
		}
		else if (s.size() == 2)
		{
			outPutChar(s.top());
			s.pop();
			outPutChar(s.top());
			s.pop();
		}
		else
		{
			cout << "00";
		}
	}
	return 0;
}

       需要注意的地方就是要清楚结果一共有三种可能,一种是00,一种是0X,一种是XX,也就是两位都是0,第一位是0,和第一位不是0这三种情况。不小心可能会导致段错误或者结果就直接错误了,其他应该没有什么需要注意的地方了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值