1025 PAT Ranking (25 分) 题解

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

这题就是排序和数组的应用,排序就调用algorithm里面封装好的sort和stable_sort函数,这个不赘述,还有就是输出的要求,输出的要求有点多,要一个一个求,从左到右依次是编号,总排名,归属于哪个list,和在那个list中的当地排名,我直接就用了一个vector来储存所有的list,然后用结构体作为数据结构,排序的先后顺序也不赘述了,这题不难,只要依次实现就行,下面放上我的代码。

#include<iostream>
#include<vector>
#include<string>
#include<algorithm>
using namespace std;

struct Node
{
	string index;
	int score;
	int rankList;
	int location;
	int localRank;
};

bool compareScore(Node a, Node b)
{
	return a.score > b.score;
}
bool compareIndex(Node a, Node b)
{
	for (int i = 0; i < 13; i++)
	{
		if (a.index[i] < b.index[i])
		{
			return true;
		}
		else if (a.index[i] > b.index[i])
		{
			return false;
		}
	}
}

int main()
{
	int m;
	cin >> m;
	vector<Node> arr;
	int start = 0;
	for (int i = 0; i < m; i++)
	{
		int n;
		cin >> n;
		start += n;
		vector<Node> arrTemp;
		for (int j = 0; j < n; j++)
		{
			Node node;
			cin >> node.index;
			cin >> node.score;
			node.location = i + 1;
			arr.push_back(node);
			arrTemp.push_back(node);
		}
		sort(arrTemp.begin(), arrTemp.end(), compareScore);
		int number = -1;
		for (int k = 0; k < n; k++)
		{
			if (number == arrTemp[k].score)
			{
				arrTemp[k].localRank = arrTemp[k - 1].localRank;
			}
			else
			{
				arrTemp[k].localRank = k + 1;
				number = arrTemp[k].score;
			}
		}
		for (int k = start-n; k< start; k++)
		{
			for (int t = 0; t < n; t++)
			{
				if (arr[k].index == arrTemp[t].index)
				{
					arr[k].localRank = arrTemp[t].localRank;
					break;
				}
			}
		}
	}
	sort(arr.begin(), arr.end(),compareIndex);
	stable_sort(arr.begin(),arr.end(),compareScore);
	int number = -1;
	for (int i = 0; i < arr.size(); i++)
	{
		if (number == arr[i].score)
		{
			arr[i].rankList = arr[i - 1].rankList;
		}
		else
		{
			arr[i].rankList = i + 1;
			number = arr[i].score;
		}
	}
	cout <<arr.size()<< endl;
	for (int i = 0; i < arr.size(); i++)
	{
		cout << arr[i].index << " "<< arr[i].rankList<<" "<< arr[i].location<<" "<< arr[i].localRank<< endl;
	}
	system("pause");
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值