hdu-1017 A Mathematical Curiosity

Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
  
  
1 10 1 20 3 30 4 0 0
 

Sample Output
  
  
Case 1: 2 Case 2: 4 Case 3: 5
  

这是杭电网站上算法类的水题,格式类的坑题。

题意理解
题意为给出两个数n,m,要求出n内的两个数a,b满足0<a<b<n。并且( (a^2+b^2 +m)/(ab)的结果为一整数的a,b的组数。


格式理解
样例输入中1的含义为可以测试的组数,其含义为如果输入0,0代表一组数据的输入结束。如果输入的组数为10,则表示要输入10个0,0才表示总输入的结束。输入0,0只表示一小组输入数据的结束。为方便大家理解,请允许我来展示一下我无师自通的制表能力。
如输入组数一开始为3
10 1   case1:   2                                            20  3   case1:  4                              10  1   case1:  2
20 3   case2:4                                            10  1   case2:2                             30  4   case2:  5
30 4   case3:   5                                            30  4   case3:5                             20  3   case3:  4
0 0 输入结束                                               0,0  输入结束                              0,0输入结束
这是3组输入数据中的第一组。              这是3组中的第二组                       第三组输入结束(总输入结束)
聪明的你明白小明的意思了吗?

AC代码
#include <stdio.h>
#include <string.h>
#include <math.h>
int main(void)
{
    int m,n,i,a,b,t,z,w=0;
    double rem;
    scanf("%d",&z);
    i=z;
    do{
        while (scanf("%d %d",&n,&m)!=EOF) {
            t=0;
            if(n==0&&m==0){
                w=0;
                z--;
                if(z!=0)
                    printf("\n");
                break;
            }
            
            for(a=1;a<n;a++){
                for(b=a+1;b<n;b++){
                    rem=(a*a+b*b+m)*(1.0)/(a*b*1.0);
                    if((int)rem==rem)
                        t++;
                }
            }
            w++;
            printf("Case %d: ",w);
            printf("%d\n",t);
        }
    }while(z>0);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值