[PAT A1055]The World's Richest

[PAT A1055]The World’s Richest

题目描述

1055 The World’s Richest (25 分)Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world’s wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

输入格式

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

输出格式

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person’s information occupies a line, in the format
Name Age Net_Worth
The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

输入样例

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

输出样例

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

解析

  1. 题目大意:首先输入N和K,N表示总共纳入统计的人的个数,K表示要查询的数目,接下来N行,输入一个人的姓名,年龄,和他的资产数。输入完之后,接下来输入K行数据,每一行有三个数,分别是容量,最小年龄,最大年龄,我们需要做的是输出这个年龄段里面的人的信息,并且不超过容量,例如在a到b年龄段有20个人,但是容量是16,那么我们不能全部输出,只能输入16个人
  2. 输出格式是:按照资产非升序排列,如果资产相同,那么按照年龄从低到高排列,如果年龄也相同,那么按照姓名升序排列。
  3. 具体代码和解析如下,我的思路是首先把所有人按照资产数排序,这样我们在从头遍历数组的时候,就已经保证了资产是从高到低排列的了,然后只需要按照要求输出在年龄段之间的人的信息就行了:
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;
struct person
{
 string name; //姓名
 int worth, age;  //资产数和年龄
};
bool cmp(person p1, person p2)  //重写的cmp函数
{
 if (p1.worth != p2.worth) return p1.worth > p2.worth;
 if (p1.age != p2.age) return p1.age < p2.age;
 else return p1.name < p2.name;
}
int main()
{
 int N, K;
 vector<person> pers; //vector数组
 cin >> N >> K;
 while (N--) {   //使用while循环输入信息
  person p;
  cin >> p.name;
  scanf("%d%d", &p.age, &p.worth);
  pers.push_back(p);
 }
 sort(pers.begin(), pers.end(), cmp);
 for (int i = 1; i <= K; i++) {
  int all, min, max, index = 0; //index用于保证输入的数据没有超过容量
  scanf("%d%d%d", &all, &min, &max);
  printf("Case #%d:\n", i);
  for (int i = 0; index < all && i < pers.size(); i++) {
   if (pers[i].age <= max && pers[i].age >= min) {
    printf("%s %d %d\n", pers[i].name.c_str(), pers[i].age, pers[i].worth);
    index++;
   }
  }
  if (index == 0) printf("None\n");
 }
 return 0;
}

4.很关键的一点就是还是要使用scanf和printf,这样可以节省时间,我第一次测试就是没有使用这两个输入输出,结果导致第二组数据没有办法通过,切记切记!

水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值