[PAT B1029/A1084]Broken Keyboard

[PAT B1029/A1084]Broken Keyboard

本题是甲级1084和乙级1029题,所以先放英文题目,如果是要做乙级题的话,可以不看英文,直接看下面的中文题

题目描述

1084 Broken Keyboard (20 分)On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.
Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

输入格式

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

输出格式

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

输入样例

7_This_is_a_test
_hs_s_a_es

输出样例

7TI

--------------------------中文原题---------------------------

题目描述

1029 旧键盘 (20 分)旧键盘上坏了几个键,于是在敲一段文字的时候,对应的字符就不会出现。现在给出应该输入的一段文字、以及实际被输入的文字,请你列出肯定坏掉的那些键。

输入格式

输入在 2 行中分别给出应该输入的文字、以及实际被输入的文字。每段文字是不超过 80 个字符的串,由字母 A-Z(包括大、小写)、数字 0-9、以及下划线 _(代表空格)组成。题目保证 2 个字符串均非空。

输出格式

按照发现顺序,在一行中输出坏掉的键。其中英文字母只输出大写,每个坏键只输出一次。题目保证至少有 1 个坏键。

解析

是一道关于散列的简单题,最关键就是要想到使用hashTable[128]来标记字符,我的思路是如果输入一个字符,就令对应位置的数+1,第二遍输入b的时候就令对应位置得数-1,这样如果键盘坏了的话,那么最终这个位置的数字就不为0

#include<iostream>
#include<string>
#include<cctype>
using namespace std;
int hashTable[128];
int main()
{
 string a, b;
 cin >> a >> b;
 for (int i = 0; i < a.length(); i++) {
  if (islower(a[i])) a[i] = toupper(a[i]);
 }
 for (int i = 0; i < b.length(); i++) {
  if (islower(b[i])) b[i] = toupper(b[i]);
 }
 for (int i = 0; i < a.length(); i++) hashTable[a[i]]++;
 for (int i = 0; i < b.length(); i++) hashTable[b[i]]--;
 for (int i = 0; i < a.length(); i++) {
  if (hashTable[a[i]]) {
   printf("%c", a[i]);
   hashTable[a[i]] = 0;
  }
 }
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值