[PAT A1008]Elevator

[PAT A1008]Elevator

题目描述

1008 Elevator (20 分)The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

输入格式

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

输出格式

For each test case, print the total time on a single line.

输入样例

3 2 3 1

输出样例

41

解析

题目很简单,大致意思就是输入n个数,每个数表示电梯将要在哪一层停靠,每上升一层需要6秒钟,下降一层需要4秒钟,停靠一层开关门时间需要5秒钟,要我们计算总的用时是多少。这个题目就要要求一遍能通过是最好的。

#include<iostream>
using namespace std;
int main()
{
 int n;
 scanf("%d", &n);
 int pos = 0, time = 0;//电梯当前所在位置
 for (int i = 0; i < n; i++) {
  int des;      //目标楼层
  scanf("%d", &des);
  if (des > pos) {
   time += (des - pos) * 6;
   pos = des;
  }
  else {
   time += (pos - des) * 4;
   pos = des;
  }
 }
 time += n * 5;
 printf("%d", time);
 return 0;
}
水平有限,如果代码有任何问题或者有不明白的地方,欢迎在留言区评论;也欢迎各位提出宝贵的意见!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值