[PAT A1071]Speech Patterns

[PAT A1071]Speech Patterns

题目描述

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

输入格式

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

输出格式

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

输入样例

Can1: "Can a can can a can? It can!"

输出样例

can 5

解析

  1. 题目的大意就是输入一行字符串,需要我们统计出现的次数最多的字符串,并将该字符串和它出现的次数一并输出;如果这样的字符串有多个,则输出按字典序最小的。
  2. 注意,这里的字符串就是由[0~9 a~z A~Z]组成的,所以Can1和can是不同的
  3. 注意,统计的时候是不分大小写的,所以Can和can是一样的,所以我们第一步是先要将大写字母转化为小写字母。
  4. 这里有一个简单的函数可以判断字符串的某一位是否符合由[0~9 a~z A~Z]组成这个条件,就是isalnum()函数,所以我们程序中使用的isalpha()和isdigital()两个函数可以化简为isalnum()
  5. #include<iostream>
    #include<string>
    #include<cctype>
    #include<map>
    using namespace std;
    int main()
    {
    	string str;
    	map<string, int> cnts;//使用图来存储每个字符串出现的次数
    	getline(cin, str);
    	for (int i = 0; i < str.length(); i++) {
    		if (isupper(str[i])) str[i] = tolower(str[i]);//把大写字母转化为小写字母
    	}
    	int i = 0;
    	while (i < str.length()) {
    		while (i < str.length() && (!(isdigit(str[i]) || isalpha(str[i]))))i++;
    		int j = i;
    		while (j < str.length() && (isdigit(str[j]) || isalpha(str[j])))j++;
    		string subs = str.substr(i, j - i);
    		cnts[subs]++;
    		i = j;
    	}//这部分函数实现的是统计合法字符串,并使得该字符串对应的次数+1
    	int max = -1;
    	string ans;
    	for (map<string, int>::iterator it = cnts.begin(); it != cnts.end(); it++) {
    		if (it->second > max) {
    			max = it->second;
    			ans = it->first;
    		}
    	}//寻找出现次数最大的数,由于map是有序的,故不用再比较
    	cout << ans << " " << max;
    	return 0;
    }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值