[PAT A1004]Counting Leaves

[PAT A1004]Counting Leaves

题目描述

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

输入格式

Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

输出格式

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

输入样例

2 1
01 1 02

输出样例

0 1

解析

1.题目描述:首先输入n和m,n表示树中的结点个数,m表示树中非叶结点个数。对于每个非叶结点,我们首先输出它的id,然后输出它的子结点个数,然后依次输出子结点的编号。然后我们对于每一层结点都要输出该层叶结点的个数。

2.与其他树的题目没有太大的区别,题目也不算很难。具体代码如下:

#include<iostream>
#include<vector>
using namespace std;
const int maxn = 110;  //不超过100个结点,这里我设为110稍大一点
int cnt[maxn] = { 0 };  //记录某层叶结点个数数组
int maxl = -1;       //记录最深的层数
vector<int> tree[maxn]; //数组模拟树
void traverse(int i, int level);
int main()
{
	int n, m;
	scanf("%d %d", &n, &m);
	for (int i = 0; i < m; i++) {
		int num, t, temp;
		scanf("%d %d", &num, &t);
		for (int j = 0; j < t; j++) {
			scanf("%d", &temp);
			tree[num].push_back(temp);
		}
	}
	traverse(1, 0);
	for (int i = 0; i <= maxl; i++) {  //主要用于计算树的高度
		printf("%d", cnt[i]);
		if (i != maxl) printf(" ");
	}
	return 0;
}
void traverse(int i, int level)
{
	if (level > maxl) maxl = level;  //如果当前结点的深度比最大深度要深,则更新
	if (tree[i].empty()) {  //如果没有子结点,即该结点为叶结点,更新cnt数组
		cnt[level]++;
		return;
	}
	for (int j = 0; j < tree[i].size(); j++) traverse(tree[i][j], level + 1);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值