hdu - 5187 zhx's contest

As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem's difficulty is i. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p

.

Input

Multiply test cases(less than 1000

). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. (1≤n,p≤1018

)

Output

For each test case, output a single line indicating the answer.

Sample Input

2 233
3 5

Sample Output

2
1


        
  

Hint

In the first case, both sequence {1, 2} and {2, 1} are legal.
In the second case, sequence {1, 2, 3}, {1, 3, 2}, {2, 1, 3}, {2, 3, 1}, {3, 1, 2}, {3, 2, 1} are legal, so the answer is 6 mod 5 = 1
        
 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5187

题意:从1~n有多少种排列,使得 a1~ai 满足单调递增或者单调递减,ai~an 满足单调递增或者递减。

全递增或全递减或最大或最小放在中间任一位置(减去全递增或全递减),公式2*(2^(n-1)-2)+2 = 2^n - 2。特别注意一下n=1时的两种情况wa了好多法了.......

#include<iostream>
#include<cstdio>
using namespace std;

typedef long long ll;

ll n, p;

ll mut_k(ll a, ll b)
{
	ll ans = 0;
	while(b > 0)
	{
		if(b & 1)
			ans = (ans+a) % p;
		a = (a+a) % p;
		b >>= 1;
	}
	return ans%p;
}
	
ll pow_k(ll a, ll b)
{
	ll ans = 1;
	while(b > 0)
	{
		if(b & 1)
			ans = mut_k(ans, a);
		a = mut_k(a, a);
		b >>= 1;
	}
	return ans%p;
}
int main()
{
	
	while(~scanf("%lld%lld", &n, &p))
	{
		if(n==1)
		{
			if(p == 1)
				cout << 0 << endl;
			else
				cout << 1 << endl;
		}
		else
		{
			cout << (pow_k(2,n)+p-2) % p<< endl;
		}
		
	}
	return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值