HDU 5187 zhx's contest (高精度快速幂)

Problem Description

As one of the most powerful brushes, zhx is required to give his juniors n problems.
zhx thinks the ith problem's difficulty is i. He wants to arrange these problems in a beautiful way.
zhx defines a sequence {ai} beautiful if there is an i that matches two rules below:
1: a1..ai are monotone decreasing or monotone increasing.
2: ai..an are monotone decreasing or monotone increasing.
He wants you to tell him that how many permutations of problems are there if the sequence of the problems' difficulty is beautiful.
zhx knows that the answer may be very huge, and you only need to tell him the answer module p.

 

Input

Multiply test cases(less than 1000). Seek EOF as the end of the file.
For each case, there are two integers n and p separated by a space in a line. (1≤n,p≤1018)

Output

For each test case, output a single line indicating the answer.

Sample Input

2 233

3 5

Sample Output

2

1

 

 

题意:给你一个n,让你求n个数组成前i个是单调递增,后n-i个是单调递减,或者是前i个是单调递减,后n-i个是单调递增

答案对p取余。

解题思路:我们以n==4为例子

前i个是单调递减,后n-i个是单调递增

1 2 3 4

2 1 3 4

3 1 2 4

4 1 2 3

3 2 1 4

4 2 1 3

4 3 1 2

4 3 2 1

前i个是单调递增,后n-i个是单调递减

4 3 2 1

1 4 3 2

2 4 3 1

3 4 2 1

1 2 4 3

1 3 4 2

2 3 4 1

1 2 3 4

 

我们可以看到有两项是重复出现的,所以答案为2*2^(n-1)-2===2^n-2

这题用高精度的快速幂加速一下就行了

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn=1010;
#define ll long long
ll n,m;
ll mul(ll a,ll b,ll c){
	ll ret=0,temp=a%c;
	while(b){
		if(b&1){
			ret+=temp;
			if(ret>=c) ret-=c;
		}
		temp<<=1;
		if(temp>=c) temp-=c;
		b>>=1;
	}
	return ret;
}
ll quick(ll a,ll b,ll mod){
	ll ret=1;
	while(b){
		if(b&1) ret=mul(ret,a,mod);
		a=mul(a,a,mod);
		b>>=1;
	}
	return ret;
}
int main(){
	int i,j;
	while(scanf("%lld%lld",&n,&m)!=EOF){
		ll ans=quick(2,n,m);
		printf("%lld\n",(ans-2+m)%m);
	}
	return 0;
}

 

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,HDU1622是一道关于二叉树的题目,要求读入一系列二叉树的节点信息,输出它们的层序遍历结果。如果输入的二叉树不完整或存在重复节点,则输出"not complete"。下面是Java的实现代码: ```java import java.util.LinkedList; import java.util.Queue; import java.util.Scanner; public class Main { static class Node { int val; Node left, right; public Node(int val) { this.val = val; } } public static void main(String[] args) { Scanner sc = new Scanner(System.in); while (sc.hasNext()) { String s = sc.nextLine(); if (s.isEmpty()) { continue; } String[] nodes = s.split("\\s+"); Node root = new Node(Integer.parseInt(nodes[0].substring(1))); Queue<Node> queue = new LinkedList<>(); queue.offer(root); boolean isComplete = true; for (int i = 1; i < nodes.length - 1; i += 2) { Node cur = queue.poll(); if (!nodes[i].equals("()")) { cur.left = new Node(Integer.parseInt(nodes[i].substring(1))); queue.offer(cur.left); } else { isComplete = false; } if (!nodes[i + 1].equals("()")) { cur.right = new Node(Integer.parseInt(nodes[i + 1].substring(0, nodes[i + 1].length() - 1))); queue.offer(cur.right); } else { isComplete = false; } } if (!isComplete) { System.out.println("not complete"); continue; } StringBuilder sb = new StringBuilder(); queue.offer(root); while (!queue.isEmpty()) { Node cur = queue.poll(); sb.append(cur.val).append(" "); if (cur.left != null) { queue.offer(cur.left); } if (cur.right != null) { queue.offer(cur.right); } } System.out.println(sb.toString().trim()); } } } ```

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值