PAT 1021 Deepest Root

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤10​4​​) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

 大概题意:给出n点,并输入n-1条边。然后问你连通分支的数量,是1的话,输出最深的树,可能的根节点。

#include <cstdio> 
#include <iostream>
#include <algorithm>
#include <vector>
#include <set>
#include <cstring>
using namespace std;

const int maxn = 1e4+5;
int n, maxd;
bool vis[maxn];
vector<int> mp[maxn];
vector<int> ans;
set<int> s;



void dfs(int node, int d)
{
    if(d > maxd)
	{
        ans.clear();
        ans.push_back(node);
        maxd = d;
    }
	else if(d == maxd)
        ans.push_back(node);
    
    vis[node] = 1;
    for(int i = 0; i < mp[node].size(); i++)
        if(!vis[mp[node][i]])
            dfs(mp[node][i], d+1);
        
}

int main()
{
    int cnt = 0;
    int sr; // 查找哪一点为最深树的根节点 
    scanf("%d",&n);
    memset(vis, 0, sizeof vis);
    for(int i = 1; i < n; i++)
	{
		int a, b;
        scanf("%d%d", &a, &b);
        mp[a].push_back(b);
        mp[b].push_back(a);
    }
    for(int i = 1; i <= n; i++)
	{
        if(!vis[i])
		{
            dfs(i, 0);
            cnt++; // 连通分支 
            sr = ans[0];
            for(int j = 0;j < ans.size(); j++)
                s.insert(ans[j]);
        }
    }
    if(cnt != 1)
       printf("Error: %d components", cnt);
    else
	{
        memset(vis, 0, sizeof vis);
        ans.clear();
        dfs(sr, 0); // 从该点再重新dfs过去 
        for(int i = 0; i < ans.size(); i++)
            s.insert(ans[i]);
        for(set<int>::iterator it = s.begin(); it != s.end(); it++)
            printf("%d\n", *it);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值