返回值练习

【问题描述】
两位正整数的简单算术运算(只考虑整数运算),算术运算为:
+,加法运算;
-,减法运算;
*,乘法运算;
/,整除运算;
%,取余运算。
算术表达式的格式为(运算符前后可能有空格):
运算数 运算符 运算数
请输出相应的结果。
输入: 一行算术表达式。
输出: 整型算数运算的结果(结果值不一定为2位数,可能多于2位或少于2位)。
【样例输入】32+64
【样例输出】96

c++代码:

#include<iostream>
using namespace std;
int yunsuan(int a,char c,int b){
	if(c=='+'){
		return a+b;
	}else if(c=='-'){
		return a-b;
	}else if(c=='*'){
		return a*b;
	}else if(c=='/'){
		return a/b;
	}else if(c=='%'){
		return a%b;
	}
}
int main(){
	int a,b;
	char c;
	cin>>a>>c>>b;
	cout<<yunsuan(a,c,b);
	return 0;
}

python代码:

inp=input().split(' ')
a=int(inp[0])
c=inp[1]
b=int(inp[2])
def yunsuan(a,c,b):
    if c=='+':
        return a+b
    elif c=='-':
        return a-b
    elif c=='*':
        return a*b
    elif c=='/':
        return a//b
    elif c=='%':
        return a%b
print(yunsuan(a,c,b))

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

ChenWenKen

你的鼓励是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值