题目
Description
There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.
You know that there are n students in your university
(0<n≤50000)
. It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask
m
Input
The input consists of a number of cases. Each case starts with a line specifying the integers
n
and
Output
For each test case, print on a single line the case number (starting with 1 <script type="math/tex" id="MathJax-Element-14">1</script> ) followed by the maximum number of different religions that the students in the university believe in.
Sample Input
10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample Output
Case 1: 1
Case 2: 7
Hint
Huge input, scanf is recommended.
分析
并查集模板题,不多说,直接上代码
代码
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<queue>
#include<stack>
#include<vector>
#include<cmath>
#include<set>
#include<map>
#include<cstdlib>
#include<functional>
#include<climits>
#include<cctype>
#include<iomanip>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
#define mod 1e9+7
#define clr(a,x) memset(a,x,sizeof(a))
const double eps = 1e-6;
int religion[1000000];
int find(int a)
{
if(religion[a]!=a)
religion[a]=find(religion[a]);
return religion[a];
}
void merge(int a,int b)
{
int fx,fy;
fx=find(a);
fy=find(b);
if(fx!=fy)
religion[fx]=fy;
}
int main()
{
int a,b;
int t,n;
int kase=0;
while(scanf("%d%d",&t,&n)==2,t+n)
{
int cnt=0;
clr(religion,0);
for(int i=1;i<=t;i++)
{
religion[i]=i;
}
for(int i=0;i<n;i++)
{
scanf("%d%d",&a,&b);
merge(a,b);
}
for(int i=1;i<=t;i++)
{
if(find(i)==i)
cnt++;
}
printf("Case %d: %d\n",++kase,cnt);
}
return 0;
}