数据结构实验之链表六:有序链表的建立

数据结构实验之链表六:有序链表的建立
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。
Input
第一行输入整数个数N;
第二行输入N个无序的整数。
Output
依次输出有序链表的结点值。
Sample Input
6
33 6 22 9 44 5
Sample Output
5 6 9 22 33 44
Hint
不得使用数组!

#include <stdio.h>
#include <stdlib.h>
int n;
struct node
{
    int data;
    struct node *next;
};
struct node* create(int n)
{
    struct node*head, *t;
    head = (struct node*)malloc(sizeof(struct node));
    head->next = NULL;
    t = head;
    while(n--)
    {
        struct node*p;
        p = (struct node*)malloc(sizeof(struct node));
        p->next = NULL;
        scanf("%d", &p->data);
        t->next = p;
        t = p;
    }
    return head;
}
void show(struct node*head)
{
    struct node *p;
    p = head->next;
    while(p)
    {
        printf("%d%c", p->data, p->next==NULL? '\n': ' ');
        p = p->next;
    }
    return;
}
void f(struct node*head)
{
    struct node*p, *q;
    int t1;
    for(p=head->next; p->next!=NULL; p = p->next)
    {
        for(q=p->next; q; q = q->next)
        {
            if(p->data > q->data)
            {
                t1 = p->data;
                p->data = q->data;
                q->data = t1;
            }
        }
    }
    show(head);
    return;
}
int main()
{
    scanf("%d",&n);
    struct node *head;
    head = create(n);
    f(head);
    return 0;
}


/***************************************************
User name: jk160532姜兴友
Result: Accepted
Take time: 0ms
Take Memory: 144KB
Submit time: 2017-10-08 15:12:52
****************************************************/
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值