计算长方形的周长和面积(类和对象)

计算长方形的周长和面积(类和对象)
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic Discuss
Problem Description
设计一个长方形类Rect,计算长方形的周长与面积。
成员变量:整型、私有的数据成员length(长)、width(宽);
构造方法如下:
(1)Rect(int length) —— 1个整数表示正方形的边长
(2)Rect(int length, int width)——2个整数分别表示长方形长和宽
成员方法:包含求面积和周长。(可适当添加其他方法)
要求:编写主函数,对Rect类进行测试,输出每个长方形的长、宽、周长和面积。
Input
输入多组数据;
一行中若有1个整数,表示正方形的边长;
一行中若有2个整数(中间用空格间隔),表示长方形的长度、宽度。
若输入数据中有负数,则不表示任何图形,长、宽均为0。
Output
每行测试数据对应一行输出,格式为:(数据之间有1个空格)
长度 宽度 周长 面积
Sample Input
1
2 3
4 5
2
-2
-2 -3
Sample Output
1 1 4 1
2 3 10 6
4 5 18 20
2 2 8 4
0 0 0 0
0 0 0 0
Hint

Source
zhouxq

import java.util.*;
public class Main{
    public static void main(String args[]) {
        Scanner cin = new Scanner(System.in);

        while(cin.hasNext()) {
            Rect re;
            String str = cin.nextLine();
            String s[] = str.split(" ");//以空格为界限分是s[0], s[1]等
            if(s.length==1) {
                int len = Integer.parseInt(s[0]);//把String转化为int型
                re = new Rect(len);
            }
            else {
                int len = Integer.parseInt(s[0]);
                int wid = Integer.parseInt(s[1]);
                re = new Rect(len, wid);
            }
            System.out.printf("%d %d %d %d\n", re.length, re.width, (re.length+re.width)*2, re.length*re.width);
        }
    }
}
class Rect{
    int length, width;
    Rect(int length1){
        if(length1<0)
            length1 = 0;
        length = length1;
        width = length1;
    }
    Rect(int length1, int width1){
        if(length1<0)
            length1 = 0;
        if(width1<0)
            width1=0;
        length = length1;
        width = width1;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值