计算长方体、四棱锥的表面积和体积

计算长方体、四棱锥的表面积和体积
Time Limit: 1000 ms Memory Limit: 65536 KiB
Submit Statistic
Problem Description
计算如下立体图形的表面积和体积。

从图中观察,可抽取其共同属性到父类Rect中:长度:l 宽度:h 高度:z

在父类Rect中,定义求底面周长的方法length( )和底面积的方法area( )。

定义父类Rect的子类立方体类Cubic,计算立方体的表面积和体积。其中表面积area( )重写父类的方法。

定义父类Rect的子类四棱锥类Pyramid,计算四棱锥的表面积和体积。其中表面积area( )重写父类的方法。

输入立体图形的长(l)、宽(h)、高(z)数据,分别输出长方体的表面积、体积、四棱锥的表面积和体积。

Input
输入多行数值型数据(double);

每行三个数值,分别表示l h z

若输入数据中有非正数,则不表示任何图形,表面积和体积均为0。

Output
行数与输入相对应,数值为长方体表面积 长方体体积 四棱锥表面积 四棱锥体积(中间有一个空格作为间隔,数值保留两位小数)

Sample Input
1 2 3
0 2 3
-1 2 3
3 4 5
Sample Output
22.00 6.00 11.25 2.00
0.00 0.00 0.00 0.00
0.00 0.00 0.00 0.00
94.00 60.00 49.04 20.00
Hint
四棱锥体公式:V=1/3Sh,S——底面积 h——高

Source
zhouxq

import java.util.*;
class Rect{
    double l, h, z;
    Rect(){

    }
    Rect(double x, double y, double q){
        l = x;h = y;z = q;
    }
    double zhouchang() {
        return 2*(l+h);
    }
    double area() {
        return l*h;
    }
}
class Cubic extends Rect{
    Cubic(double x, double y, double q){
        super(x, y, q);
    }
    double area() {
        return 2*(h*l+l*z+h*z);
    }
    double v_Cubic() {
        return h*l*z;
    }
}
class Pyramid extends Rect{
    Pyramid(double x, double y, double q) {
        super(x, y, q);
    }
    double area() {
        return h*l + l*Math.sqrt(z*z + h*h/4)+ h*Math.sqrt(z*z+l*l/4);
    }
    double v_Pyramid() {
        return l*h*z/3;
    }
}
public class Main {
    public static void main(String []args){
        Scanner cin = new Scanner(System.in);
        while(cin.hasNext()) {
            double l, h, z;
            l = cin.nextDouble();
            h = cin.nextDouble();
            z = cin.nextDouble();
            if(l<=0||h<=0||z<=0) {
                System.out.printf("0.00 0.00 0.00 0.00\n");
                continue;
            }
            Cubic c = new Cubic(l, h, z);
            Pyramid p = new Pyramid(l, h, z);
            System.out.printf("%.2f %.2f %.2f %.2f\n", c.area(), c.v_Cubic(), p.area(), p.v_Pyramid());
        }
        cin.close();
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值