A + B Problem II

A + B Problem II
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 407298 Accepted Submission(s): 78892

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211

Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

就是将两个数加到一起,两个数个数可以相同,可以不同
注意的关键是格式
// 就是将整数 和字符进行转换

在c++中
//整数转字符
int a= 5;
char c = int(5-'0')

// 字符转整数
char c = '5';
int a = c+48;
利用的是ASCII码
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main()
{
    int n, c;
    cin >> n;
    char arr1[1001], arr2[1001];
    int arr3[1001];
    for (c = 0;  c < n; c++)
    {
        scanf("%s",arr1);
        int len1 = strlen(arr1);
        getchar();

        scanf("%s",arr2);
        int len2 = strlen(arr2);
        getchar();

        int t = 0, it = 0;
        int i = len1-1,j = len2-1;
        for ( ; i>=0 && j>=0; i--,j--)
        {

            // 字符 转整型
            t = t + int(arr1[i]-'0') + int(arr2[j]-'0');
            if (t > 9)
            {
//                t = t-10;
                arr3[it] = t-10;
                t = 1;
            }
            else
            {
                arr3[it] = t;
                t = 0;
            }
            it++;

        }

        if (i>j)
        {
            for (; i >=0; i--)
            {
                arr3[it] = int(arr1[i] - '0') + t;
                t = 0;
                it++;
            }

        }
        if (i < j)
        {
            for (; j >= 0; j--)
            {
                arr3[it] = int(arr2[j] - '0') + t;
                t = 0;
                it++;
            }
        }
//      printf("Case %d:\n",c+1);
//      printf("%s + %s = ",arr1,arr2);
        cout << "Case " << c+1 << ":"<<endl;
        cout << arr1 << " + " << arr2 << " = ";
        for (int i = it-1; i >= 0; i--)
        {
            cout << arr3[i];
        }
        cout << endl;

        // 格式注意
        if (c != n-1)
            cout << endl;


    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值