PAT 甲级 A1100

1100 Mars Numbers (20分)

题目描述

People on Mars count their numbers with base 13:

  • Zero on Earth is called “tret” on Mars.
  • The numbers 1 to 12 on Earth is called “jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec” on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as “tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou”, respectively.

For examples, the number 29 on Earth is called “hel mar” on Mars; and “elo nov” on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

输入格式

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

输出格式

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

总结

  1. 数据量不大,因此可直接开数组,而且查询是双向。因此可以用一个循环来做简单的判断,进行打表处理。
  2. 注意一个特殊情况,当n可被13整除时结果只有一个火星数字,比如题中13 <=> tam26 <=> het

AC代码

#include <iostream>
#include<string>
#include<ctype.h>
#include<map>
using namespace std;
map<string, int> MarsToEarth;
string EarthToMars[169];
string mars[13] = { "tret", "tam", "hel", "maa", "huh", "tou", "kes", "hei", "elo", "syy", "lok", "mer", "jou" };
string earth[13] = { "tret","jan", "feb", "mar", "apr", "may", "jun", "jly", "aug", "sep", "oct", "nov", "dec" };
void init() {
	for (int i = 0; i < 169; i++) {
		int a = i / 13, b = i % 13;
		if (a==0) {//0-12
			MarsToEarth[earth[i]] = i;
			EarthToMars[i] = earth[i];
		}
		else if(b!=0){ //>13且无法被13整除,15=>a=1,b=2
			MarsToEarth[mars[a] + " " +earth[b]] = i;
			EarthToMars[i] = mars[a] + " " + earth[b];
		}
		else{ //可被13整除,0,13,26
			MarsToEarth[mars[a]] = i;
			EarthToMars[i] = mars[a];
		}
	}
}
int main() {
	int n;
	string temp;
	scanf("%d", &n);
	getchar();
	init();
	while (n--) {
		getline(cin, temp);
		if (isdigit(temp[0])) {
			cout << EarthToMars[stoi(temp)] << endl;
		}
		else {
			printf("%d\n", MarsToEarth.find(temp)->second);
		}
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值