PAT 甲级 A1086

1086 Tree Traversals Again (25分)

题目描述

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Figure 1

输入格式

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: “Push X” where X is the index of the node being pushed onto the stack; or “Pop” meaning to pop one node from the stack.

输出格式

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

总结

  1. 题意是用栈模拟一个二叉树的中序序列,给出出栈入栈的操作,让你写出这个栈的后续序列
  2. 刚开始看得挺蒙,后来观察发现,这个入栈序列刚好对应了二叉树的先序遍历,出栈序列对应了二叉树的中序遍历。有了先序遍历和后序遍历的结果,就可以唯一确定出一棵唯一的二叉树了。
  3. 开始测试点4过不去,原因是入栈的时候我用字符串的最后一位-'0’来得到int类型的入栈元素。刚开始没想到两位数就不能用这个方法了- -||,这个点卡了我半天…太粗心了我

AC代码

#include <iostream>
#include<cstring>
#include<stack>
using namespace std;
int n, pre[35], in[35];
struct node
{
	int val;
	node*left, *right;
};
node*createBiTree(int preL,int preR,int inL,int inR) {
	if (preL > preR) return nullptr;   //递归出口
	node*root = new node;
	root->val = pre[preL];   //根节点的值
	int k = inL;
	while (in[k] != root->val && k < inR)k++;

	int numL = k - inL;
	root->left = createBiTree(preL + 1, preL + numL, inL, k - 1);
	root->right = createBiTree(preL + numL + 1, preR, k + 1, inR);
	return root;
}
void showPostTraversal(node*root,int&index) {
	if (root) {
		showPostTraversal(root->left, index);
		showPostTraversal(root->right, index);
		index++;
		printf("%d", root->val);
		if (index < n) printf(" ");
	}
}
int main() {
	int preR = 0, inR = 0;
	stack<int> s;
	scanf("%d", &n);
	getchar();
	for (int i = 0; i < 2*n; i++) {
		char temp[5];
		scanf("%s", temp);
		if (strcmp(temp,"Push")==0) {  //注意不要用 字符-'0'的方式得到int型数字,如果数字超过10,这个方式就不行了
			int val;
			scanf("%d", &val);
			s.push(val);          //进栈为先序
			pre[preR++] = val;
		}
		else { //出栈为中序
			in[inR++] = s.top();
			s.pop();
		}
	}
	int index = 0;
	showPostTraversal(createBiTree(0, n - 1, 0, n - 1), index);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值