HDU 1856 More is better(简单并查集) 【最大并查集人数模板】

Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 
Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8
Sample Output
4
2


        
  
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), 
then A and C are also friends(indirect).

 In the first sample {1,2,5,6} is the result.
In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

 【题意】一个房间,空间足够大,现在有n个人(1<=n<=10000000),编号1~n,现在给出m组关系,每组两个数a,b,代表代表a和b直接是朋友,现在求最大的朋友圈人数,比如Hint。

 【分析】并查集合并数组,最后找出人数最多的那个输出即可。


  虽然数组看着很大,但好在效率高,只用时499ms完过。

 【代码】

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e7+3;
int a[N],num[N];

int check(int x)
{
    if(x==a[x])return a[x];
    else return a[x]=check(a[x]);
}

void unionn(int x,int y)
{
    int aa=check(x);
    int bb=check(y);
    if(aa==bb) return ;
    a[bb]=aa;

    num[aa]+=num[bb];//很重要 -- 顺序
}

int main()
{
    int m,n,x,y;
    while(~scanf("%d",&m))
    {
        for(int i=1;i<N;i++)
        {
            a[i]=i;
            num[i]=1;
        }
        while(m--)
        {
            scanf("%d%d",&x,&y);
            unionn(x,y);
        }
        int ans=0;

        for(int i=1;i<N;i++)
        {
            if(a[i]==i)
                ans=max(ans,num[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值