POJ 3250 Bad Hair Day(单调)

Some of Farmer John's N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows' heads.

Each cow i has a specified height hi (1 ≤ h≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =
=       =
=   -   =         Cows facing right -->
=   =   =
= - = = =
= = = = = =
1 2 3 4 5 6 

Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow's hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow's hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input
Line 1: The number of cows,  N
Lines 2..N+1: Line  i+1 contains a single integer that is the height of cow  i.
Output
Line 1: A single integer that is the sum of  c  1 through  cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5
  【题意】n头奶牛站成一排,从左往右看,只要右边高度<=自己高度的都可以看到,但是一旦遇到比自己高的,则它后面的奶牛都看不到,即计数停止,要计算所有牛向右所能看到的数目和。(奶牛哪知道哪边是左哪边是右~~~汗,,,)

  【AC代码】

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
const int N=8e4+5;

int main()
{
    int m,n;
    ll a[N],vis[N];
    while(~scanf("%d",&m))
    {
        ll ans=0; //long long 可以通过
        memset(a,0,sizeof(a));
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=m;i++)
        {
            scanf("%lld",&a[i]);
            vis[i]=i;
        }
        for(int i=m-1;i>0;i--)
        {
            int s=i;
            while(a[s+1]<a[i]&&s<m)//相等也看不到
                s=vis[s+1];
            vis[i]=s;
        }

        for(int i=1;i<=m;i++)
            ans+=(vis[i]-i);
        printf("%lld\n",ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值