HDU1078 FatMouse and Cheese(记忆化搜索)

23 篇文章 0 订阅

Description

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food. 

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole. 

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input

There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 

Output

For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1

Sample Output

37

题意

给出一个n*n的矩阵,和可以走的距离,每个位置都有奶酪数量,第二次走的位置奶酪数量只能比第一次的位置奶酪数量多,求出最大可以获得的奶酪数量。

思路

简单的搜索题,如果直接搜索就会超时

 

就像这个样子,必须要进行记忆化处理才可以过。

代码如下:

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
int n,k;
int c[110][110],dp[110][110];
int f[4][2]={1,0,0,1,-1,0,0,-1};//上下左右走的方向
int slove(int a,int b)
{
	if(dp[a][b]!=0)
		return dp[a][b];//进行记忆化处理。
	int maxn=0;
	for(int i=1;i<=k;i++)
	{
		for(int j=0;j<4;j++)
            {
			int l1=f[j][0]*i+a;
			int l2=f[j][1]*i+b;//四个走的方向
			if(l1>=0&&l1<n&&l2>=0&&l2<n&&c[l1][l2]>c[a][b])//不出界并且当前获得最大值比以前的大
                {
				if(slove(l1,l2)>maxn)
					maxn=slove(l1,l2);
			}
		}
	}
	    dp[a][b]=maxn+c[a][b];
	return dp[a][b];
}
int main()
{
	while(~scanf("%d %d",&n,&k)&&!(n==-1&&k==-1))
      {
		for(int i=0;i<n;i++)
		    for(int j=0;j<n;j++)
			  scanf("%d",&c[i][j]);
		memset(dp,0,sizeof(dp));
		printf("%d\n",slove(0,0));
	}
	return 0;
}

 

 

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值