POJ 3626 Mud Puddles(BFS)【模板】

Farmer John is leaving his house promptly at 6 AM for his daily milking of Bessie. However, the previous evening saw a heavy rain, and the fields are quite muddy. FJ starts at the point (0, 0) in the coordinate plane and heads toward Bessie who is located at (XY) (-500 ≤ X ≤ 500; -500 ≤ Y ≤ 500). He can see all N (1 ≤ N ≤ 10,000) puddles of mud, located at points (AiBi) (-500 ≤ Ai ≤ 500; -500 ≤ Bi ≤ 500) on the field. Each puddle occupies only the point it is on.

Having just bought new boots, Farmer John absolutely does not want to dirty them by stepping in a puddle, but he also wants to get to Bessie as quickly as possible. He's already late because he had to count all the puddles. If Farmer John can only travel parallel to the axes and turn at points with integer coordinates, what is the shortest distance he must travel to reach Bessie and keep his boots clean? There will always be a path without mud that Farmer John can take to reach Bessie.

Input

* Line 1: Three space-separate integers: XY, and N.
* Lines 2..N+1: Line i+1 contains two space-separated integers: Ai and Bi

Output

* Line 1: The minimum distance that Farmer John has to travel to reach Bessie without stepping in mud.

Sample Input
1 2 7
0 2
-1 3
3 1
1 1
4 2
-1 1
2 2
Sample Output
11

 【题解】 宽搜题,原本第一次看过去以为是图呢,没想到是宽搜,10000个点。。。结果宽搜竟然过了,还很快,这是道宽搜的模板题型,下面附上代码。

 【AC代码】

 

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int N=500;
int mapp[2005][2005];
int p[2005][2005];
int dx[4]={0,0,1,-1},dy[4]={-1,1,0,0};
int ans;

struct tree
{
    int x,y;
    int step;
};

int main()
{
    int st,ed,n,m,nx,ny;
    scanf("%d%d%d",&st,&ed,&n);
    st+=500,ed+=500;
    tree node,next;
    for(int i=1;i<=n;++i)
    {
        scanf("%d%d",&nx,&ny);
        nx+=500;
        ny+=500;
        mapp[nx][ny]=1;
    }
    node.x=500;
    node.y=500;
    node.step=0;
    memset(p,0,sizeof(p));
    p[500][500]=1;
    queue<tree>q;
    while(!q.empty()) q.pop();
    q.push(node);
    ans=0;
    while(!q.empty())
    {
        node=q.front();
        q.pop();
        for(int i=0;i<4;++i)
        {
            int xx=node.x+dx[i];
            int yy=node.y+dy[i];
            if(xx>=0&&xx<=1000&&yy>=0&&yy<=1000&&!p[xx][yy]&&!mapp[xx][yy])
            {
                next.step=node.step+1;
                next.x=xx;
                next.y=yy;
                p[xx][yy]=1;
                if(p[st][ed]==1)
                {
                    ans=next.step;
                    goto loop;
                }
                q.push(next);
            }
        }
    }
    loop:
        printf("%d\n",ans);
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值