POJ 1383 Labyrinth (技巧BFS)

The northern part of the Pyramid contains a very large and complicated labyrinth. The labyrinth is divided into square blocks, each of them either filled by rock, or free. There is also a little hook on the floor in the center of every free block. The ACM have found that two of the hooks must be connected by a rope that runs through the hooks in every block on the path between the connected ones. When the rope is fastened, a secret door opens. The problem is that we do not know which hooks to connect. That means also that the neccessary length of the rope is unknown. Your task is to determine the maximum length of the rope we could need for a given labyrinth.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers C and R (3 <= C,R <= 1000) indicating the number of columns and rows. Then exactly R lines follow, each containing C characters. These characters specify the labyrinth. Each of them is either a hash mark (#) or a period (.). Hash marks represent rocks, periods are free blocks. It is possible to walk between neighbouring blocks only, where neighbouring blocks are blocks sharing a common side. We cannot walk diagonally and we cannot step out of the labyrinth. 
The labyrinth is designed in such a way that there is exactly one path between any two free blocks. Consequently, if we find the proper hooks to connect, it is easy to find the right path connecting them.
Output
Your program must print exactly one line of output for each test case. The line must contain the sentence "Maximum rope length is X." where Xis the length of the longest path between any two free blocks, measured in blocks.
Sample Input
2
3 3
###
#.#
###
7 6
#######
#.#.###
#.#.###
#.#.#.#
#.....#
#######
Sample Output
Maximum rope length is 0.
Maximum rope length is 8.
Hint
Huge input, scanf is recommended. 
If you use recursion, maybe stack overflow. and now C++/c 's stack size is larger than G++/gcc

 【题解】

 大致题意,在图中找到一条最长的空白链,.表示空白区域。


 分析:

 这道题本来不难,都知道用宽搜,但是从哪里搜,是个问题,理想的起始点当然是空白区域的某个角落处,所以这里是个要脑袋转弯的地方。

 所以我们就先用一次BFS,从任一点出发,目的是找离当前点最远的点,由于当前点是任意的点,所以距离最远的点一定是图中空白区域的一个顶点,就是我们的理想起始点,所以从这里再搜,搜到的就一定是最长的空白区域链。


 【AC代码】

 

#include<algorithm>
#include<iostream>
#include<cstring>
#include<stdio.h>
#include<math.h>
#include<string>
#include<stdio.h>
#include<queue>
#include<stack>
#include<map>
#include<vector>
#include<deque>
using namespace std;
#define lson k*2
#define rson k*2+1
#define M (t[k].l+t[k].r)/2
#define INF 1008611111
int p[1005][1005],n,m;
char s[1005][1005];
int dirx[4]={0,0,-1,1};
int diry[4]={-1,1,0,0};
int maxx,stx,sty;
struct node
{
    int x,y;
    int step;
};
void bfs(int x,int y)
{
    node now,next;
    queue<node>q;
    now.x=x,now.y=y,now.step=0;
    q.push(now);
    memset(p,0,sizeof(p));
    maxx=0;
    int i,j,xx,yy;
    p[x][y]=1;
    while(!q.empty())
    {
        now=q.front();
        q.pop();
        if(now.step>maxx)
        {
            maxx=now.step;
            stx=now.x;
            sty=now.y;
        }
        for(i=0;i<4;i++)
        {
            xx=now.x+dirx[i];
            yy=now.y+diry[i];
            if(xx>=0&&yy>=0&&xx<m&&yy<n&&!p[xx][yy]&&s[xx][yy]!='#')
            {
                p[xx][yy]=1;
                next.x=xx;
                next.y=yy;
                next.step=now.step+1;
                q.push(next);
            }
        }
    }
}
int main()
{
    int i,j,k,test;
    scanf("%d",&test);
    while(test--)
    {
         scanf("%d%d",&n,&m);
        for(i=0;i<m;i++)
        {
            scanf("%s",s[i]);
        }
        for(i=0;i<m;i++)
        {
            for(j=0;j<n;j++)
            {
                if(s[i][j]=='.')
                {
                    bfs(i,j); //从任意空点开始搜
                    goto loop;
                }
            }
        }
        loop:;
        bfs(stx,sty);//这里的stx,sty是第一次搜到的最长距离的点  也就是这个图空白处的一个顶点位置
        //这里宽搜是从最远位置出发寻找最大距离
        printf("Maximum rope length is %d.\n",maxx);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值