POJ-1276 Cash Machine

Cash Machine
原题链接
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 38286 Accepted: 13906
Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
Sample Output

735
630
0
0
Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
Source

Southeastern Europe 2002

取款机
[原题链接](http://poj.org/problem?id=1276
时间限制:1000MS内存限制:10000K
总提交:38286接受:13906
描述

银行计划安装一台取款机。该机器能够为请求的现金量提供适当的@票据。该机器使用正好N个不同的纸币面值,例如Dk,k = 1,N,并且对于每个面额Dk,机器具有nk纸币的供应量。例如,

N = 3,n1 = 10,D1 = 100,n2 = 4,D2 = 50,n3 = 5,D3 = 10

表示该机器有10个每个@ 100的帐单,每个@ 50个4个帐单和每个@ 10个5个帐单。

请致电现金机器应交付的请求数量的现金,并编写一个计划,根据机器的可用纸币供应计算最大现金金额小于或等于可以有效交付的现金。

笔记:
@是机器交付货币的象征。例如,@可以代表美元,欧元,英镑等。
输入

程序输入来自标准输入。输入中的每个数据集表示特定的事务并具有以下格式:

现金N n1 D1 n2 D2 … nN DN

其中0 <=现金<= 100000是要求的现金数量,0 <= N <= 10是票据面额数量,0 <= nk <= 1000是Dk面额的可用票据数量,1 <= 1000。 Dk <= 1000,k = 1,N。输入中的数字之间可以自由地出现空格。输入数据是正确的。
输出

对于每组数据,程序都将结果打印到单独的行上的标准输出,如下面的示例所示。
示例输入

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
示例输出

735
630
0
0
提示

第一个数据集指定一个交易,其中请求的现金金额为@ 735。该机器包含3张面值的纸币:@ 125张4张钞票,@ 5张6张钞票和@ 350张3张钞票。该机器可以提供确切数量的请求现金。

在第二种情况下,机器的账单供应量不符合要求的确切金额。可以交付的最大现金是@ 630。请注意,可能有多种可能性将机器中的钞票合并为交付的现金。

在第三种情况下,机器是空的,没有现金交付。在第四种情况下,请求的现金量为@ 0,因此,机器不提供现金。
资源

欧洲东南部2002年

题解
题目的大意是给你几张钞票,让你凑一个最接近 n 的数字。
带系数的 01背包 ,果断想到二进制拆分(因为系数很大,有1000个,二进制拆分后得到。
不知道二进制拆分的点这里

代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxv=100005,maxn=15;
bool f[maxv];
int allv,n,a,b,allm;
int main()
{
    while (~scanf("%d",&allv))
    {
        scanf("%d",&n);
        memset(f,1,sizeof f);f[0]=0;
        for (int i=1;i<=n;i++)
        {
            scanf("%d%d",&b,&a);
            for (int j=1;b-j>=0;j<<=1)//二进制拆分
            {
                b-=j;a*=j;
                for (int k=allv;k>=a;k--)
                  if (f[k]) f[k]=f[k-a];
                a/=j;
            }
            if (b)//未拆完的部分
            {
                a*=b;
                for (int k=allv;k>=a;k--)
                  if (f[k]) f[k]=f[k-a];
            }
        }
        int ans=allv;
        while (f[ans]) ans--;
        printf("%d\n",ans);
    }
    return 0;
}
  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值