(数位dp)F(x)

For a decimal number x with n digits (A nA n-1A n-2 … A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + … + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
Output
For every case,you should output “Case #t: ” at first, without quotes. The t is the case number starting from 1. Then output the answer.
Sample Input
3
0 100
1 10
5 100
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
const int maxn=20;
ll a,b;
int arr[maxn];
ll dp[maxn][5000];
int xx;
ll cal(ll x)
{
    ll ans=0;
    int l=0;
    while(x)
    {
        ans+=(x%10)*(1<<l);
        l++;x/=10;
    }
    return ans;
}
ll dfs(int pos,int state,bool limit)
{
    if(pos==0) return state>=0;
    if(state<0) return 0;
    if(!limit&&dp[pos][state]!=-1) return dp[pos][state];
    int up=limit?arr[pos]:9;
    ll ans=0;
    for(int i=0;i<=up;i++)
    {
        int s=state-i*(1<<(pos-1));
        ans+=dfs(pos-1,s,limit&&i==up);
    }
    if(!limit) dp[pos][state]=ans;
    return ans;
}
ll solve(ll x)
{
    ll pos=0;
    while(x)
    {
        arr[++pos]=x%10;
        x/=10;
    }
    return dfs(pos,xx,1);
}
int main()
{
    int t,num=0;
    scanf("%d",&t);
    memset(dp,-1,sizeof(dp));//注意初始化要写在循环外面防止重复计算,不然会TLE
    while(t--)
    {
        scanf("%lld%lld",&a,&b);
        xx=cal(a);
        printf("Case #%d: %lld\n",++num,solve(b));
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值