HDU 1372 Knight Moves

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11424    Accepted Submission(s): 6712


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". 
 

Sample Input
  
  
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

Sample Output
  
  
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
 

题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=1372

   分析

       由题目可以知道是计算骑士从一个位置到另个位置需要走的最少的步数,而棋盘中骑士的移动方式跟象棋中的马的移动方式是相同的,所以移动方式应为象棋中马的移动方式



#include<iostream>
#include<string>
#include<string.h>
#include<sstream>
#include<queue>
using namespace std;
struct node//定义结构体来存放位置和到达此位置的步数
{
    int x,y,step;
} s,e;
string n,m;
int dir[8][2]= {{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1},{-1,2}};//存放各个可能走的方向
void bfs()//计算步数
{
    queue<node>q;
    node t,x1;
    q.push(s);//将起始位置入队
    while(!q.empty())
    {
        t=q.front();//用t存放队首元素的信息
        q.pop();//将队首元素出队
        for(int i=0; i<8; i++)//判断八个方向的情况
        {
            x1.step=t.step+1;//步数比上个位置+1
            x1.y=t.y+dir[i][1];
            x1.x=t.x+dir[i][0];
            if(x1.x>=0&&x1.x<8&&x1.y>=0&&x1.y<8)//判断此位置是否在棋盘内
            {
                if(x1.x==e.x&&x1.y==e.y)//如果此位置为终点,输出步数并返回到主函数
                {
                    cout<<"To get from "<<n<<" to "<<m<<" takes "<<x1.step<<" knight moves."<<endl;
                    return;
                }
                q.push(x1);//否则的会将此位置入队
            }
        }
    }
}
int main()
{
    while(cin>>n>>m)
    {	//将起点和终点的坐标变为数字坐标
        s.x=n[0]-'a';
        s.y=n[1]-'1';
        e.x=m[0]-'a';
        e.y=m[1]-'1';
        s.step=0;//起始步数为0
        if(s.x==e.x&&s.y==e.y)cout<<"To get from "<<n<<" to "<<m<<" takes 0 knight moves."<<endl;//起点终点重合需0步
        else bfs();//起点终点不重合则调用函数计算步数
    }
}


  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值