17暑假多校联赛1.11 HDU 6043 KazaQ's Socks

KazaQ’s Socks

Time Limit: 2000/1000 MS (Java/Others)
Memory Limit: 131072/131072 K (Java/Others)

Problem Description

KazaQ wears socks everyday.
At the beginning, he has n pairs of socks numbered from 1 to n in his closets.
Every morning, he puts on a pair of socks which has the smallest number in the closets.
Every evening, he puts this pair of socks in the basket. If there are n−1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.
KazaQ would like to know which pair of socks he should wear on the k-th day.

Input

The input consists of multiple test cases. (about 2000)
For each case, there is a line contains two numbers n,k (2≤n≤109,1≤k≤1018).

Output

For each test case, output “Case #x: y” in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.

Sample Input
3 7
3 6
4 9
Sample Output
Case #1: 3
Case #2: 1
Case #3: 2


题目网址:http://acm.hdu.edu.cn/showproblem.php?pid=6043

分析

题意:KazaQ有n双袜子,这些袜子的编号为1-n,他穿袜子时会从衣橱里选编号最小的那一双来穿,并且每天早上穿,晚上脱下来放到篮子里存着,当篮子里的袜子数量达到n-1双时,他会将它们清洗并在第二天将它们放回衣橱里,现在知道他有n双袜子,编号为1-n,问第k天他穿的袜子编号为多少
找规律后发现,n双袜子的循环节为:除了前n天是1~n,后面的的都是1~n,1~n-1,1~n-2,n

代码
#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
int main()
{
    int res=1,n;
    ll k;
    while(~scanf("%d%I64d",&n,&k))
    {
        printf("Case #%d: ",res++);
        if(k<=n)printf("%d\n",k);
        else
        {
            k-=n;
            int s=(k/(n-1))%2,t=(k-1)%(n-1)+1;
            if(s)printf("%d\n",t);
            else printf("%d\n",t==n-1?n:t);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值