2017年河南省ACM省赛 Problem G: Plumbing the depth of lake

问题 G: Plumbing the depth of lake

时间限制: 1 Sec  内存限制: 128 MB

题目描述

There is a mysterious lake in the north of Tibet. As the sun shines, the surface of the lake is colorful and colorful. The lake was unfathomable in rainy weather.  After the probe,  It has an interesting bottom in that it is full of little hills and valleys. . Scientists wonders how deep the bottom of the lake is.

 

Scientists use the most advanced radar equipment to detect the bottom of the lake. It is the discovery that the deepest part is relatively flat. Thet want to know the largest depth number only if it is verified by the fact that the same depth appears in an adjacent reading.

 

To facilitate computing, scientists have put the lake as M * N grids . The depth  reading of each grid is already known. some readings might be 0-- It's a small island on the lake.

 

Find the greatest depth that appears in at least two 'adjacent'readings (where 'adjacent' means in any of the potentially eight squares that border a square on each of its sides and its diagonals). The lake has at least one pair of positive, adjacent readings.

输入

The first line of the input contains one integers T, which is the nember of  test cases (1<=T<=5).  Each test case specifies:

 

* Line 1:      Two space-separated integers: M and N   (1 ≤ M,  N ≤ 50)

* Lines 2..M+1: Line i+1 contains N space-separated integers that  represent the depth of the lake across row i: Dij    (0 <= Dij <=1,000,000);

输出

For each test case generate a single line:  a single integer that is the depth of the lake determined.

样例输入

1
4 3
0 1 0
1 2 0
1 5 1
2 3 4

样例输出

1

分析

题意是计算湖中可确定的最深的水深,矩阵每个位置表示该位置的水深,以某一位置为中心,它相邻的八个方向有跟中心相同的深度,则此深度为可确定的深度。很简单的问题,但是如果用搜索写的话,提交之后时间超限,所以直接暴力,用3层for循环解决

代码

#include <algorithm>
#include <iostream>
#include <string>
#include <vector>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
int d[55][55],M,N,depth;
int dir[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,-1},{1,0},{1,1}};///相邻的八个方向
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        depth=0;
        scanf("%d %d",&M,&N);
        for(int i=0; i<M; i++)
            for(int j=0; j<N; j++)
                scanf("%d",&d[i][j]);///输入湖深信息
        for(int i=0; i<M; i++)
        {
            for(int j=0; j<N; j++)
            {
                if(d[i][j]==-1)continue;///用-1来记录是否判断过
                for(int k=0;k<8;k++)///判断8个方向
                {
                    if(i+dir[k][1]>=0&&i+dir[k][1]<M&&j+dir[k][0]>=0&&j+dir[k][0]<M)///确保该位置在矩阵之内
                    {
                        if(d[i+dir[k][1]][j+dir[k][0]]==d[i][j])
                        {
                            if(d[i][j]>depth)depth=d[i][j];///depth存放最深水深
                            d[i+dir[k][1]][j+dir[k][0]]=-1;///判断过的位置赋值为-1
                            d[i][j]=-1;///判断过的位置赋值为-1
                        }
                    }
                }
            }
        }
        printf("%d\n",depth);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值