省赛 Plumbing the depth of lake

时间限制: 1 Sec  内存限制: 128 MB


题目描述

There is a mysterious lake in the north of Tibet. As the sun shines, the surface of the lake is colorful and colorful. The lake was unfathomable in rainy weather.  After the probe,  It has an interesting bottom in that it is full of little hills and valleys. . Scientists wonders how deep the bottom of the lake is.

Scientists use the most advanced radar equipment to detect the bottom of the lake. It is the discovery that the deepest part is relatively flat. Thet want to know the largest depth number only if it is verified by the fact that the same depth appears in an adjacent reading.

To facilitate computing, scientists have put the lake as M * N grids . The depth  reading of each grid is already known. some readings might be 0-- It's a small island on the lake.

Find the greatest depth that appears in at least two 'adjacent'readings (where 'adjacent' means in any of the potentially eight squares that border a square on each of its sides and its diagonals). The lake has at least one pair of positive, adjacent readings.

输入

The first line of the input contains one integers T, which is the nember of  test cases (1<=T<=5).  Each test case specifies:

* Line 1:      Two space-separated integers: M and N   (1 ≤ M,  N ≤ 50)

* Lines 2..M+1: Line i+1 contains N space-separated integers that  represent the depth of the lake across row i: Dij    (0 <= Dij <=1,000,000);

输出

For each test case generate a single line:  a single integer that is the depth of the lake determined.

样例输入

1
4 3
0 1 0
1 2 0
1 5 1
2 3 4

样例输出

1
本题题意:
    本题意思就是有一片池塘 ,池塘中有许多的小山谷,现在想知道池塘的深度。在N*M的矩阵中,0代表湖上的一个小岛。其余数字代表池塘的深度,如果其相邻的八个方向有相同的数字,则这个数为其池塘深度,现在要求能确定的池塘的最深深度。
解题思路:
    用深搜,直接搜其八个方向,用数组存其能确定的最大深度,不断刷新数组,找出最大深度即可。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
using namespace std;
int dx[8]={1,1,-1,-1,0,0,1,-1};///定义其八个方向
int dy[8]={0,1,0,-1,1,-1,-1,1};///定义其八个方向
int map[55][55];
int main()
{
    int T,M,N,i,j,k;
    scanf("%d",&T);
    while(T--)
    {
        int maxx=-1;
        memset(map,-1,sizeof(map));
        scanf("%d%d",&M,&N);
        for(i=1; i<=M; i++)
        {
            for(j=1; j<=N; j++)
            {
                scanf("%d",&map[i][j]);
            }
        }
        for(i=1; i<=M; i++)
        {
            for(j=1; j<=N; j++)
            {
                if(maxx>map[i][j])
                    continue;
                for(k=0; k<8; k++)
                {
                    if(map[i][j]==map[i+dx[k]][j+dy[k]])
                        maxx=map[i][j];
                }
            }
        }
        printf("%d\n",maxx);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值