Raising Bacteria——个人c++解

Description

You are a lover of bacteria so you want to raise some bacteria in a box. Initially, the box is empty. Every morning, you can put any number of bacteria into the box. Every night every bacterium in the box will split into two bacteria. You hope to see exactly x x bacteria in the box at some moment. What is the minimum number of bacteria you need to put into the box across those days?

 

Input

There are several test cases. Each case contains only one integer x x (1x109) (1≤x≤109) a line.

 

Output

For each case, output the only line containing one integer: the answer.

 

Sample Input

5
8

 

Sample Output

2

1


#include<bits/stdc++.h>
using namespace std;
int main()
{
    long long int i,j,n,l,q,k;
    long long int b[32];
    b[0]=1;
    for(i=0;i<31;i++)//将2的n次方保存
    {
        b[i+1]=b[i]*2;
    }
    while(scanf("%lld",&q)!=EOF)
    {
        k=0;
        while(q!=0)//每次都减去比该数小的2的n次方,为0时结束,得到结果
        {
            for(i=0;i<31;i++)
            {
                if(q>=b[i]&&q<b[i+1])
                {
                    q=q-b[i];
                    k=k+1;
                }
            }
        }
        printf("%lld\n",k);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值