KazaQ's Socks——个人c++解

问题 K: KazaQ's Socks

Problem Description

KazaQ wears socks everyday.

At the beginning, he has n pairs of socks numbered from 1 to n in his closets.

Every morning, he puts on a pair of socks which has the smallest number in the closets.

Every evening, he puts this pair of socks in the basket. If there are n1 pairs of socks in the basket now, lazy KazaQ has to wash them. These socks will be put in the closets again in tomorrow evening.

KazaQ would like to know which pair of socks he should wear on the k -th day.
 

Input


The input consists of multiple test cases. (about 2000 )

For each case, there is a line contains two numbers n,k (2n109,1k1018) .
 

Output


For each test case, output " Case # x : y " in one line (without quotes), where x indicates the case number starting from 1 and y denotes the answer of corresponding case.
 

Sample Input

  
  
3 7 3 6 4 9
 

Sample Output

Case #1: 3
Case #2: 1

Case #3: 2


找规律,

n=3时

n k  y

3 1 1

3 2 2

3 3 3

3 4 1

3 5 2

3 6 1

3 7 3

3 8 1

3 9 2

3 10 1

3 11 3

。。。。。。

#include<bits/stdc++.h>//KazaQ's Socks
using namespace std;
long long int k;
int main()
{
    long long int n,x=1,y;
    while(scanf("%lld %lld",&n,&k)!=EOF)
    {
        if(k<=n)//k<=n时,y=k;
            y=k;
        else
        if((k-n)%(n-1)==0)//判断是否到达了柜子里最后一双袜子
        {
            if((k-n)/(n-1)%2==0)//如果是偶数次到达柜子里最后一双袜子
                y=n;
            else//如果是奇数次
                y=n-1;
        }
        else//判断没有到达柜子里最后一双袜子
        y=(k-n)%(n-1);
        printf("Case #%lld: %lld\n",x,y);
        x++;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值